Bug 1283414 - rhel-osp-director: 8.0 - not possible to deploy undercloud with SSL.
rhel-osp-director: 8.0 - not possible to deploy undercloud with SSL.
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: instack-undercloud (Show other bugs)
8.0 (Liberty)
Unspecified Unspecified
urgent Severity urgent
: ga
: 8.0 (Liberty)
Assigned To: James Slagle
Alexander Chuzhoy
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-18 17:04 EST by Alexander Chuzhoy
Modified: 2016-04-07 17:43 EDT (History)
8 users (show)

See Also:
Fixed In Version: instack-undercloud-2.2.2-1.el7ost
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-07 17:43:07 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenStack gerrit 221885 None None None 2016-01-06 13:00 EST

  None (edit)
Description Alexander Chuzhoy 2015-11-18 17:04:36 EST
rhel-osp-director: 8.0 - not possible to deploy undercloud with SSL.
Environment:
instack-undercloud-2.1.3-1.el7ost.noarch

Need to add the ability to deploy undercloud with SSL.
Comment 3 Ryan Hallisey 2015-11-20 12:17:04 EST
allow dnsmasq_t default_t:dir read;

You need to relabel tftpboot.

`restorecon -Rv /tftpboot`
Comment 4 Jaromir Coufal 2016-01-04 11:49:46 EST
Should be part of global SSL work targeted for OSP8.
Comment 5 Ryan Hallisey 2016-01-04 12:16:11 EST
The labeling here will be fixed by bz#1280083.  It needs to be handled in puppet.

*** This bug has been marked as a duplicate of bug 1280083 ***
Comment 6 chris alfonso 2016-01-04 12:58:15 EST
Let's keep this open and have the two different scenarios tested, even though the fix is the same.
Comment 7 Marius Cornea 2016-01-06 07:42:11 EST
There is no undercloud_service_certificate directive in undercloud.conf.
Comment 8 Ben Nemec 2016-01-06 13:00:47 EST
Undercloud ssl is merged to upstream master.  Needs a backport to stable/liberty, and then will need a new downstream package build to pick up the changes for OSP 8.
Comment 9 Emilien Macchi 2016-02-23 08:42:20 EST
Ben, can we update this BZ maybe? It seems your upstream patch has been merged.
Comment 10 Ben Nemec 2016-02-24 17:16:55 EST
It looks like the fixed build is available in the latest puddle, so this should be ready for QA.
Comment 13 Alexander Chuzhoy 2016-02-25 15:47:42 EST
Verified:
Environment:
instack-undercloud-2.2.2-2.el7ost.noarch

Was able to deploy undercloud with SSL.
Comment 15 errata-xmlrpc 2016-04-07 17:43:07 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-0604.html

Note You need to log in before you can comment on or make changes to this bug.