Bug 1283415 - Incorrect dependencies for gnome-gmail 1.9.3
Incorrect dependencies for gnome-gmail 1.9.3
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gnome-gmail (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Guillaume Kulakowski
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-18 17:14 EST by Ville Skyttä
Modified: 2016-01-26 13:27 EST (History)
2 users (show)

See Also:
Fixed In Version: gnome-gmail-2.0.1-1.fc23
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-26 13:27:06 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ville Skyttä 2015-11-18 17:14:53 EST
$ mock -r fedora-rawhide-x86_64 --install gnome-gmail
$ mock -r fedora-rawhide-x86_64 --shell
<mock-chroot>sh-4.3# gnome-gmail
Traceback (most recent call last):
  File "/usr/share/gnome-gmail/gnomegmail.py", line 37, in <module>
    from gi.repository import Gtk
ImportError: No module named gi.repository


Fix:
-Requires:       pygobject2
+Requires:       python-gobject-base
+Requires:       libnotify
+Requires:       libwnck3
Comment 1 Guillaume Kulakowski 2015-11-19 05:14:56 EST

*** This bug has been marked as a duplicate of bug 1268672 ***
Comment 2 Ville Skyttä 2015-11-19 06:37:55 EST
This is not a duplicate of bug 1268672. That one needs the libwnck3 addition, but to resolve this you need to additionally add the libnotify and python-gobject-base dependencies, and remove the pygobject2 one.
Comment 3 Fedora Update System 2015-11-20 06:15:14 EST
gnome-gmail-1.9.3.1-2.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2015-86b94430dd
Comment 4 Fedora Update System 2015-11-20 06:15:14 EST
gnome-gmail-1.9.3.1-2.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-b5bffd6980
Comment 5 Fedora Update System 2015-11-21 12:52:39 EST
gnome-gmail-1.9.3.1-2.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update gnome-gmail'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-86b94430dd
Comment 6 Fedora Update System 2015-11-22 09:26:30 EST
gnome-gmail-1.9.3.1-2.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update gnome-gmail'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-b5bffd6980
Comment 7 Fedora Update System 2015-11-28 05:03:16 EST
gnome-gmail-1.9.4-1.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2015-4e080aa89a
Comment 8 Fedora Update System 2015-11-28 05:03:18 EST
gnome-gmail-1.9.4-1.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-558f7e7de3
Comment 9 Fedora Update System 2015-11-28 05:03:29 EST
gnome-gmail-1.9.4-1.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2015-8f43c8b02c
Comment 10 Ville Skyttä 2015-11-28 05:45:33 EST
For some reason the dependency on pygobject2 has crept back and dependency on python-gobject-base has been removed in 1.9.4-1, with no mention about it in the change log or commit message.

Also, there are more dependency problems than that:
- missing Requires: python-six
- AFAICT unneeded Requires: dbus-python
- AFAICT unneeded Requires: gnome-python2-gnomekeyring
- unneedded BuildRequires: python-distutils-extra

...and additionally, gnome-gmail now runs with Python 3 too (I ported it upstream). I'll submit a patch taking care of all this in a separate bug.

Too bad the 1.9.3.1-2 was overwritten with the worse 1.9.4-1 update, the previous one would have been good to get out ASAP.
Comment 11 Guillaume Kulakowski 2015-11-28 05:51:36 EST
Hi,

> For some reason the dependency on pygobject2 has crept back and dependency
> on python-gobject-base has been removed in 1.9.4-1, with no mention about it
> in the change log or commit message.
python-gobject-base work only on F23. Use pygobject2 allow to have the same SPEC for F22/F23/EL7.

> Also, there are more dependency problems than that:
> - missing Requires: python-six
> - AFAICT unneeded Requires: dbus-python
> - AFAICT unneeded Requires: gnome-python2-gnomekeyring
> - unneedded BuildRequires: python-distutils-extra
I look that.

> ...and additionally, gnome-gmail now runs with Python 3 too (I ported it
> upstream). I'll submit a patch taking care of all this in a separate bug.
Work with, but for a minor version I prefer let Python2 dependancies.
Comment 12 Guillaume Kulakowski 2015-11-28 05:59:45 EST
Hi,


> Also, there are more dependency problems than that:
> - missing Requires: python-six
> - AFAICT unneeded Requires: dbus-python
> - AFAICT unneeded Requires: gnome-python2-gnomekeyring
> - unneedded BuildRequires: python-distutils-extra
This work on F22/F23/EL7 ?

Gnome-GMail upstream haven't any clear list of dependancies... Another solution is to make a upstream Pull reaquest with a requirements.txt ?
Comment 13 Ville Skyttä 2015-11-28 06:24:34 EST
Let's avoid duplicate work, I already have this stuff pretty much worked out, separate bug report is just a couple of minutes away. Additionally 1.9.4 does not start at all because of issues in the glade lookup.
Comment 14 Guillaume Kulakowski 2015-11-28 12:29:25 EST
What about:
 - Publish current 1.9.4.
 - Wait for 1.9.5 to publish à Python3 version for F23 ?
Comment 15 Fedora Update System 2015-11-28 19:54:05 EST
gnome-gmail-1.9.4-1.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update gnome-gmail'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-8f43c8b02c
Comment 16 Fedora Update System 2015-11-28 21:22:46 EST
gnome-gmail-1.9.4-1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update gnome-gmail'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-558f7e7de3
Comment 17 Fedora Update System 2015-11-29 01:52:54 EST
gnome-gmail-1.9.4-1.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'yum --enablerepo=epel-testing update gnome-gmail'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2015-4e080aa89a
Comment 18 Ville Skyttä 2015-12-04 07:00:05 EST
(In reply to Guillaume Kulakowski from comment #14)
> What about:
>  - Publish current 1.9.4.
>  - Wait for 1.9.5 to publish à Python3 version for F23 ?

My changes for python 3 compatibility went into 1.9.4. Unfortunately a problem was found in them which affects 1.9.4 and 1.9.5 for all python versions, so all those updates should be unpushed.

I have submitted an upstream PR that fixes them, but they have not been merged yet. To my knowledge, the way to get a properly working version at the moment is to grab current HEAD of master (revision 0ba84eb03360f9a60660c0510f875ea27bc32f7d) and to apply both commits of this PR on top of it: https://github.com/davesteele/gnome-gmail/pull/22
Comment 19 Ville Skyttä 2015-12-04 07:28:05 EST
Also, 1.9.4 is completely broken anyway, it does not even find its glade file.

But actually, upstream 1.9.5 is fine (it reverts the python 3 changes). There are a number of other issues with the current Fedora package though, and they should be fixed. Since I already have the fixes available, I went ahead and pushed them to the master branch in git. I have not built it even for rawhide, but I suggest you take a look, merge to different branches and ship replacement updates over the current broken 1.9.4 one.
Comment 20 Mario Blättermann 2015-12-25 11:29:54 EST
(In reply to Ville Skyttä from comment #19)
> Also, 1.9.4 is completely broken anyway, it does not even find its glade
> file.
> 
Indeed, it is searching for the Glade file in /share instead of /usr/share. This is the error message:

GLib.Error: g-file-error-quark: Failed to open file '/share/gnome-gmail/gnomegmail.glade': No such file or directory (4)
Comment 21 Ville Skyttä 2016-01-10 13:00:21 EST
I've pushed an update to 2.0.1 to the master branch in git, and also requested formal co-maintainership of this package. Will request F-23+ builds soon unless there are objections.
Comment 22 Fedora Update System 2016-01-16 05:34:20 EST
gnome-gmail-2.0.1-0.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-fa97eb3809
Comment 23 Guillaume Kulakowski 2016-01-16 05:36:38 EST
See #1287373.
Comment 24 Fedora Update System 2016-01-16 07:27:34 EST
gnome-gmail-2.0.1-1.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-79515fd7a0
Comment 25 Fedora Update System 2016-01-17 14:54:27 EST
gnome-gmail-2.0.1-1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-79515fd7a0
Comment 26 Fedora Update System 2016-01-26 13:26:58 EST
gnome-gmail-2.0.1-1.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.