Bug 1283417 - Error while clicking Assigned profile link from a policy event bubble
Error while clicking Assigned profile link from a policy event bubble
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS (Show other bugs)
5.5.0
Unspecified Unspecified
medium Severity medium
: GA
: 5.6.0
Assigned To: Brian McLaughlin
Nandini Chandra
ui:policy:timeline
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-18 17:30 EST by Nandini Chandra
Modified: 2016-06-29 11:09 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-06-29 11:09:45 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screen shot of policy event bubble (77.64 KB, image/png)
2016-04-27 16:54 EDT, Nandini Chandra
no flags Details

  None (edit)
Description Nandini Chandra 2015-11-18 17:30:09 EST
Description of problem:
-------------------------
The UI blows up with this error while clicking Assigned profile link from a policy event bubble:
No Class found for explorer tree node id 'pp_16' [miq_policy/explorer]

Snippet from production.log:

[----] I, [2015-11-18T17:07:27.097443 #14569:b6f990]  INFO -- :   Parameters: {"profile"=>"16"}
[----] F, [2015-11-18T17:07:27.622049 #14569:b6f990] FATAL -- : Error caught: [RuntimeError] No Class found for explorer tree node id 'pp_16'
/var/www/miq/vmdb/app/controllers/application_controller/explorer.rb:233:in `valid_active_node'
/var/www/miq/vmdb/app/controllers/miq_policy_controller.rb:449:in `get_node_info'
/var/www/miq/vmdb/app/controllers/miq_policy_controller.rb:268:in `explorer'
/opt/rh/cfme-gemset/gems/actionpack-4.2.5/lib/action_controller/metal/implicit_render.rb:4:in `send_action'
/opt/rh/cfme-gemset/gems/actionpack-4.2.5/lib/abstract_controller/base.rb:198:in `process_action'
/opt/rh/cfme-gemset/gems/actionpack-4.2.5/lib/action_controller/metal/rendering.rb:10:in `process_action'
/opt/rh/cfme-gemset/gems/actionpack-4.2.5/lib/abstract_controller/callbacks.rb:20:in `block in process_action'
/opt/rh/cfme-gemset/gems/activesupport-4.2.5/lib/active_support/callbacks.rb:117:in `call'
/opt/rh/cfme-gemset/gems/activesupport-4.2.5/lib/active_support/callbacks.rb:117:in `call'
/opt/rh/cfme-gemset/gems/activesupport-4.2.5/lib/active_support/callbacks.rb:555:in `block (2 levels) in compile'
/opt/rh/cfme-gemset/gems/activesupport-4.2.5/lib/active_support/callbacks.rb:505:in `call'
/opt/rh/cfme-gemset/gems/activesupport-4.2.5/lib/active_support/callbacks.rb:505:in `call'
/opt/rh/cfme-gemset/gems/activesupport-4.2.5/lib/active_support/callbacks.rb:92:in `__run_callbacks__'
/opt/rh/cfme-gemset/gems/activesupport-4.2.5/lib/active_support/callbacks.rb:778:in `_run_process_action_callbacks'
/opt/rh/cfme-gemset/gems/activesupport-4.2.5/lib/active_support/callbacks.rb:81:in `run_callbacks'
/opt/rh/cfme-gemset/gems/actionpack-4.2.5/lib/abstract_controller/callbacks.rb:19:in `process_action'
/opt/rh/cfme-gemset/gems/actionpack-4.2.5/lib/action_controller/metal/rescue.rb:29:in `process_action'
/opt/rh/cfme-gemset/gems/actionpack-4.2.5/lib/action_controller/metal/instrumentation.rb:32:in `block in process_action'
/opt/rh/cfme-gemset/gems/activesupport-4.2.5/lib/active_support/notifications.rb:164:in `block in instrument'
/opt/rh/cfme-gemset/gems/activesupport-4.2.5/lib/active_support/notifications/instrumenter.rb:20:in `instrument'
/opt/rh/cfme-gemset/gems/activesupport-4.2.5/lib/active_support/notifications.rb:164:in `instrument'
/opt/rh/cfme-gemset/gems/actionpack-4.2.5/lib/action_controller/metal/instrumentation.rb:30:in `process_action'
/opt/rh/cfme-gemset/gems/actionpack-4.2.5/lib/action_controller/metal/params_wrapper.rb:250:in `process_action'
/opt/rh/cfme-gemset/gems/activerecord-4.2.5/lib/active_record/railties/controller_runtime.rb:18:in `process_action'
/opt/rh/cfme-gemset/gems/actionpack-4.2.5/lib/abstract_controller/base.rb:137:in `process'
/opt/rh/cfme-gemset/gems/actionview-4.2.5/lib/action_view/rendering.rb:30:in `process'
/opt/rh/cfme-gemset/gems/actionpack-4.2.5/lib/action_controller/metal.rb:196:in `dispatch'
/opt/rh/cfme-gemset/gems/actionpack-4.2.5/lib/action_controller/metal/rack_delegation.rb:13:in `dispatch'
/opt/rh/cfme-gemset/gems/actionpack-4.2.5/lib/action_controller/metal.rb:237:in `block in action'
/opt/rh/cfme-gemset/gems/actionpack-4.2.5/lib/action_dispatch/routing/route_set.rb:76:in `call'
/opt/rh/cfme-gemset/gems/actionpack-4.2.5/lib/action_dispatch/routing/route_set.rb:76:in `dispatch'
/opt/rh/cfme-gemset/gems/actionpack-4.2.5/lib/action_dispatch/routing/route_set.rb:45:in `serve'


Version-Release number of selected component (if applicable):
----------------------
5.5.0.11


How reproducible:
-----------------
Always


Steps to Reproduce:
------------------
1.Generate Policy events for a provider(For eg,on my appliance,I have defined this VM policy profile: Action taken - Tag VM for Event - VM Power on.So,every time a VM is powered on,the VM gets tagged.
2.View Policy events for the provider by navigating to the provider summary page,
clicking 'Monitoring' and then clicking 'Timelines'.On the Timelines page,
select 'Policy Events' in the Show option drop down.
3.Click any policy event.In the event bubble,click 'Assigned profiles'.


Actual results:
---------------
UI error


Expected results:
-----------------
No UI error


Additional info:
---------------
Comment 2 Harpreet Kataria 2015-11-25 13:11:23 EST
Brian,

Can you look into this one, looks lie the link in the Policy Event bubble is incorrect. Let me know if you have questions.

Thanks,
~Harpreet
Comment 3 Brian McLaughlin 2016-03-21 16:27:27 EDT
I was able to reproduce in the reported 5.5.0.11, but the link has been removed in the latest 5.5.z builds.  Please retest to confirm the errant link is no longer an issue.
Comment 4 Nandini Chandra 2016-04-27 16:54 EDT
Created attachment 1151622 [details]
screen shot of policy event bubble
Comment 5 Nandini Chandra 2016-04-27 16:55:50 EDT
I tested this on 5.4.0.6 and the errant link has indeed been removed.I've attached a screen shot of the policy event bubble.

Marking this as VERIFIED.
Comment 7 errata-xmlrpc 2016-06-29 11:09:45 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1348

Note You need to log in before you can comment on or make changes to this bug.