Bug 1283432 - dnf group list --installed / --available
dnf group list --installed / --available
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
23
All Linux
unspecified Severity low
: ---
: ---
Assigned To: packaging-team-maint
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-18 18:29 EST by Josh Chase
Modified: 2016-03-26 13:58 EDT (History)
6 users (show)

See Also:
Fixed In Version: dnf-1.1.7-2.fc23 dnf-1.1.7-2.fc24
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-26 13:58:16 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Josh Chase 2015-11-18 18:29:39 EST
Description of problem:

There's no clear way to list the installed dnf package groups. "dnf group list" does have an "Installed Groups" heading that includes a list of groups, but there doesn't seem to be a way to get *only* those groups for maximum greppability. Also, "dnf group info <group>" only reports the packages in the group, and not whether the group is installed or not, and leaving the group argument off seems to return the help for "dnf info", which is misleading.

The only way that I could find to get whether or not a single group is installed was to do "dnf group list <group> | grep Installed", which seems a bit backwards and undocumented.

An additional argument to "dnf group list" similar to the argument to "dnf list" would be the most logical approach and is the first thing most people will try since "dnf list installed | grep <package>" or "dnf list installed <package>" is so common.
Comment 1 Honza Silhan 2015-11-23 07:44:11 EST
we can extend "dnf group list" for "--installed/--available" arguments.
Comment 2 Abhijeet Kasurde 2016-02-23 06:27:27 EST
We can close this bugzilla as PR is merged - https://github.com/rpm-software-management/dnf/pull/438
Comment 3 Fedora Update System 2016-02-25 08:53:23 EST
dnf-plugins-core-0.1.17-1.fc23 dnf-1.1.7-1.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-0123ce82c1
Comment 4 Fedora Update System 2016-02-25 08:56:20 EST
dnf-plugins-core-0.1.17-1.fc22 dnf-1.1.7-1.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2016-f673381075
Comment 5 Fedora Update System 2016-03-09 12:19:44 EST
dnf-1.1.7-2.fc23 dnf-plugins-core-0.1.17-1.fc23 libsolv-0.6.19-2.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-0123ce82c1
Comment 6 Fedora Update System 2016-03-09 12:21:32 EST
dnf-1.1.7-2.fc22 dnf-plugins-core-0.1.17-1.fc22 libsolv-0.6.19-2.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2016-f673381075
Comment 7 Fedora Update System 2016-03-10 11:52:57 EST
dnf-1.1.7-2.fc22, dnf-plugins-core-0.1.17-1.fc22, libsolv-0.6.19-2.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-f673381075
Comment 8 Fedora Update System 2016-03-10 11:54:31 EST
dnf-1.1.7-2.fc23, dnf-plugins-core-0.1.17-1.fc23, libsolv-0.6.19-2.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-0123ce82c1
Comment 9 Fedora Update System 2016-03-13 19:54:57 EDT
dnf-1.1.7-2.fc23, dnf-plugins-core-0.1.17-1.fc23, libsolv-0.6.19-2.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.
Comment 10 Fedora Update System 2016-03-19 08:16:03 EDT
dnf-1.1.7-2.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-c030d24231
Comment 11 Fedora Update System 2016-03-19 23:57:53 EDT
dnf-1.1.7-2.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-c030d24231
Comment 12 Fedora Update System 2016-03-26 13:57:44 EDT
dnf-1.1.7-2.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.