Bug 1283485 - Warning messages seen in glusterd logs in executing gluster volume set help
Warning messages seen in glusterd logs in executing gluster volume set help
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: core (Show other bugs)
mainline
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Atin Mukherjee
glusterd
: Triaged
Depends On:
Blocks: 1243351 1283833 1283834
  Show dependency treegraph
 
Reported: 2015-11-19 01:29 EST by Atin Mukherjee
Modified: 2016-06-16 09:45 EDT (History)
7 users (show)

See Also:
Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1243351
: 1283833 1283834 (view as bug list)
Environment:
RHEL7
Last Closed: 2016-06-16 09:45:21 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Atin Mukherjee 2015-11-19 01:29:11 EST
+++ This bug was initially created as a clone of Bug #1243351 +++

Description of problem:
-----------------------
gluster volume set help fails to find certain shared object (so) files and log a warning message

However there is no functional impact

Version-Release number of selected component (if applicable):
-------------------------------------------------------------
Mainline

How reproducible:
-----------------
Always

Steps to Reproduce:
-------------------
Execute gluster volume set help

Actual results:
---------------
Warning messages are seen in glusterd logs ( /var/log/glusterfs/etc-glusterfs-glusterd.vol.log as below :

<snip>
[2015-07-15 11:48:38.130329] W [MSGID: 101095] [xlator.c:143:xlator_volopt_dynload] 0-xlator: /usr/lib64/glusterfs/3.7.1/xlator/rpc-transport/socket.so: cannot open shared object file: No such file or directory
[2015-07-15 11:48:38.223781] W [MSGID: 101095] [xlator.c:143:xlator_volopt_dynload] 0-xlator: /usr/lib64/glusterfs/3.7.1/xlator/configuration.so: cannot open shared object file: No such file or directory
[2015-07-15 11:48:42.822541] I [MSGID: 106487] [glusterd-handler.c:1402:__glusterd_handle_cli_list_friends] 0-glusterd: Received cli list req
[2015-07-15 11:48:38.130383] W [MSGID: 101095] [xlator.c:143:xlator_volopt_dynload] 0-xlator: /usr/lib64/glusterfs/3.7.1/xlator/rpc-transport/socket.so: cannot open shared object file: No such file or directory
[2015-07-15 11:48:38.223849] W [MSGID: 101095] [xlator.c:143:xlator_volopt_dynload] 0-xlator: /usr/lib64/glusterfs/3.7.1/xlator/configuration.so: cannot open shared object file: No such file or directory
</snip>
Comment 1 Vijay Bellur 2015-11-19 01:37:57 EST
REVIEW: http://review.gluster.org/12656 (core : Use correct path in dlopen for socket.so) posted (#1) for review on master by Atin Mukherjee (amukherj@redhat.com)
Comment 2 Niels de Vos 2015-11-19 04:02:37 EST
Please provide a public description of the issue, including error messages and the like. This makes it possible for other users to find this bug.
Comment 3 Vijay Bellur 2015-11-19 10:18:34 EST
COMMIT: http://review.gluster.org/12656 committed in master by Jeff Darcy (jdarcy@redhat.com) 
------
commit 5dd1ecae7519f9d3910962d310356e07902a8fd0
Author: Atin Mukherjee <amukherj@redhat.com>
Date:   Thu Nov 19 12:00:23 2015 +0530

    core : Use correct path in dlopen for socket.so
    
    This patch fixes the path for socket.so file while loading the so dynamically.
    Also for config.memory-accounting & config.transport voltype is changed to
    glusterd to fix the warning message coming from xlator_volopt_dynload
    
    Change-Id: I0f7964814586f2018d4922b23c683f4e1eb3098e
    BUG: 1283485
    Signed-off-by: Atin Mukherjee <amukherj@redhat.com>
    Reviewed-on: http://review.gluster.org/12656
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Niels de Vos <ndevos@redhat.com>
    Reviewed-by: Jeff Darcy <jdarcy@redhat.com>
Comment 4 Niels de Vos 2016-06-16 09:45:21 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.