Bug 128349 - cannot make ssh connection with kermit
cannot make ssh connection with kermit
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: ckermit (Show other bugs)
2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Peter Vrabec
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-07-21 20:21 EDT by Matthew Walker
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-02 10:20:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch adds "-DHAVE_PTMX" to KFLAGS in spec file (344 bytes, text/plain)
2004-11-02 09:52 EST, Peter Vrabec
no flags Details

  None (edit)
Description Matthew Walker 2004-07-21 20:21:54 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040510

Description of problem:
In FC1, after kermit started, I was able to type "ssh hostname" to
form a connection.  In FC2 after issuing that command, kermit just
returns with a normal kermit prompt; no error is produced, but no
connection is formed either.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Start kermit
2. Type "ssh hostname", where hostname is the name of a ssh server
3. kermit will return after a few seconds.  No connection.  No error. 
    

Actual Results:  No connection is made.  No error is produced.

Expected Results:  A connection to hostname should be formed.  I
expected to see a terminal screen.

Additional info:
Comment 1 Matthew Walker 2004-07-21 20:27:07 EDT
I was able to fix this problem by downloading version 8.0.211 and
recompiling from source.

I do not know if it was a bug in kermit that was fixed, or if it was
just that the recompile fixed a clash with a library.  I suspect it
was a problem with a library because the same binary used to work in FC1.

If you have any questions please email me.
Comment 2 Krzysztof Chmielewski 2004-11-01 14:42:42 EST
LEGACY_PTYS should be enabled in kernel config.
Comment 3 Barry K. Nathan 2004-11-02 02:22:04 EST
Why should they be enabled?? To the best of my knowledge, programs
that use them need to be fixed to not use them.
Comment 4 Krzysztof Chmielewski 2004-11-02 03:14:26 EST
I agree, but AFAIK version included in Fedora Core 2 (and also in
Fedora Core 3 test 3) isn't fixed. I don't say this is right, but as a
workaroud I need to enable LEGACY_PTYS.
Comment 5 Peter Vrabec 2004-11-02 09:52:45 EST
Created attachment 106067 [details]
patch adds "-DHAVE_PTMX" to KFLAGS in spec file

Note You need to log in before you can comment on or make changes to this bug.