Bug 1283505 - when scrubber is scheduled scrubd moves the files to hot tier
when scrubber is scheduled scrubd moves the files to hot tier
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: tier (Show other bugs)
3.1
Unspecified Unspecified
unspecified Severity high
: ---
: RHGS 3.1.2
Assigned To: Bug Updates Notification Mailing List
RamaKasturi
: ZStream
Depends On:
Blocks: 1260783
  Show dependency treegraph
 
Reported: 2015-11-19 02:52 EST by RamaKasturi
Modified: 2016-09-17 11:42 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-01 00:56:01 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description RamaKasturi 2015-11-19 02:52:03 EST
Description of problem:
when a scrubber is scheduled on a tiered volume, scrubber moves all the files present in cold tier to hot tier.

scrubd should not move files in cold tier to hot tier.

Version-Release number of selected component (if applicable):
glusterfs-3.7.5-6.el6rhs.x86_64

How reproducible:
Always

Steps to Reproduce:
1. create a tiered volume
2. Enable bitrot on the volume
3. Fuse mount the volume and schedule scrubber frequency as hourly.


Actual results:
Once scrubber scrub the files in the cold tier all of them are moved to hot tier.

Expected results:
scrubd should not move the files to hot tier.

Additional info:
Comment 2 RamaKasturi 2015-11-19 04:45:11 EST
sos reports can be found at http://rhsqe-repo.lab.eng.blr.redhat.com/sosreports/1283507/
Comment 3 Joseph Elwin Fernandes 2015-11-24 07:44:05 EST
This is fixed upstream
http://review.gluster.org/#/c/12555/
http://review.gluster.org/12568

and also in downstream, 

https://code.engineering.redhat.com/gerrit/61241

should be available in new build.
Comment 4 Joseph Elwin Fernandes 2015-11-24 07:51:36 EST
new build is made today. So the coming build should have it.
Comment 5 RamaKasturi 2015-11-25 04:41:45 EST
Verified and works fine with build glusterfs-3.7.5-7.el7rhgs.x86_64.

When scrubd scans the files, files does not get promoted to hot tier.
Comment 8 errata-xmlrpc 2016-03-01 00:56:01 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0193.html

Note You need to log in before you can comment on or make changes to this bug.