Bug 1283520 - python-redis is not installed with director
python-redis is not installed with director
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-puppet-elements (Show other bugs)
8.0 (Liberty)
Unspecified Unspecified
urgent Severity unspecified
: ga
: 8.0 (Liberty)
Assigned To: Emilien Macchi
Yurii Prokulevych
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-19 03:24 EST by Yurii Prokulevych
Modified: 2016-04-07 17:43 EDT (History)
11 users (show)

See Also:
Fixed In Version: openstack-tripleo-puppet-elements-0.0.2-3.el7ost
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-07 17:43:12 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenStack gerrit 252071 None None None Never

  None (edit)
Description Yurii Prokulevych 2015-11-19 03:24:59 EST
Description of problem:
python-redis is required by openstack-polling services to run.
Right now it's not installed with director.

excerpt from 
ceilometer-polling[14956]: verify_requirements,
ceilometer-polling[14956]: File "/usr/lib/python2.7/site-packages/stevedore/named.py", line 123, in _load_one_plugin
ceilometer-polling[14956]: verify_requirements,
ceilometer-polling[14956]: File "/usr/lib/python2.7/site-packages/stevedore/extension.py", line 185, in _load_one_plugin
ceilometer-polling[14956]: plugin = ep.load(require=verify_requirements)
ceilometer-polling[14956]: File "/usr/lib/python2.7/site-packages/pkg_resources.py", line 2260, in load
ceilometer-polling[14956]: entry = __import__(self.module_name, globals(),globals(), ['__name__'])
ceilometer-polling[14956]: File "/usr/lib/python2.7/site-packages/tooz/drivers/redis.py", line 26, in <module>
ceilometer-polling[14956]: import redis
ceilometer-polling[14956]: ImportError: No module named redis


Version-Release number of selected component (if applicable):
openstack-ceilometer-api-5.0.0-1.el7ost.noarch
openstack-ceilometer-central-5.0.0-1.el7ost.noarch
openstack-ceilometer-common-5.0.0-1.el7ost.noarch
openstack-ceilometer-compute-5.0.0-1.el7ost.noarch
python-ceilometerclient-1.5.0-1.el7ost.noarch
openstack-ceilometer-polling-5.0.0-1.el7ost.noarch
openstack-ceilometer-collector-5.0.0-1.el7ost.noarch
python-ceilometer-5.0.0-1.el7ost.noarch
openstack-ceilometer-notification-5.0.0-1.el7ost.noarch
openstack-ceilometer-alarm-5.0.0-1.el7ost.noarch

rpm -qa | grep redis
redis-2.8.21-1.el7ost.x86_64

Steps to Reproduce:
Command used to deploy overcloud:
openstack overcloud deploy --libvirt-type qemu  --control-scale=3 --compute-scale=1 --ceph-storage-scale=0 -e /usr/share/openstack-tripleo-heat-templates/environments/puppet-pacemaker.yaml --templates --ntp-server <Server>


Actual results:
Traceback in log. 

Expected results:
python-redis is installed
Comment 2 Jaromir Coufal 2015-11-25 12:13:56 EST
Eoghan, would you consider this as a dependency for ceilometer?

If it is optional dependency only, it requires additional work in director (disk-image-builder at least) and this would probably miss OSP8 release.
Comment 3 Eoghan Glynn 2015-12-08 06:18:38 EST
Jaromir, yes python-redis is a dependency of tooz in the mode in which we recommend tooz is used for coordination between ceilometer central agents.

Without tooz, then the central agent cannot be run in active/active mode.
Comment 6 Yurii Prokulevych 2016-03-16 11:10:07 EDT
Verified with openstack-tripleo-puppet-elements-0.0.4-1.el7ost.noarch.
python-redis is installed and ceilometer-central is running on controllers.
Comment 8 errata-xmlrpc 2016-04-07 17:43:12 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-0604.html

Note You need to log in before you can comment on or make changes to this bug.