Bug 1283529 - unable to remove slave from bond and use it to create another bond in one request.
unable to remove slave from bond and use it to create another bond in one req...
Status: CLOSED DUPLICATE of bug 1283528
Product: vdsm
Classification: oVirt
Component: Core (Show other bugs)
4.17.11
Unspecified Unspecified
unspecified Severity unspecified (vote)
: ---
: ---
Assigned To: Dan Kenigsberg
Aharon Canan
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-19 03:48 EST by Martin Mucha
Modified: 2015-11-19 08:37 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-19 08:37:36 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: planning_ack?
rule-engine: devel_ack?
rule-engine: testing_ack?


Attachments (Terms of Use)
zipped supervdsm.log (137.98 KB, application/zip)
2015-11-19 03:49 EST, Martin Mucha
no flags Details

  None (edit)
Description Martin Mucha 2015-11-19 03:48:31 EST
Description of problem:
unable to remove slave from bond and use it to create another bond in one request.

How reproducible:
seems to be affected by nic status. If nic is down, operation seems to succeed.

Steps to Reproduce:
1. setup host with 4 nics. Use 3 of them to create bond.
2. in ovirt-engine UI detach one slave and create bond using this nic and fourth nic. Confirm dialog.


Actual results:
Error while executing action HostSetupNetworks: Interface already in use

Expected results:
operation succeeds.

Additional info:

<JsonRpcRequest id: "29681444-f287-4e7c-b11d-4ef0d936a125", method: Host.setupNetworks, params: {"networks":{},"bondings":{bond0={nics=[dummy_31, dummy_30], options=mode=4 miimon=100}, bond1={nics=[dummy_32, dummy_40], options=mode=4 miimon=100}},"options":{connectivityTimeout=120, connectivityCheck=true}}>


MainProcess|jsonrpc.Executor/4::ERROR::2015-11-19 09:36:02,656::supervdsmServer::118::SuperVdsm.ServerCallback::(wrapper) Error in setupNetworks
Traceback (most recent call last):
  File "/usr/share/vdsm/supervdsmServer", line 116, in wrapper
    res = func(*args, **kwargs)
  File "/usr/share/vdsm/supervdsmServer", line 241, in setupNetworks
    return setupNetworks(networks, bondings, **options)
  File "/usr/share/vdsm/network/api.py", line 944, in setupNetworks
    _handleBondings(bondings, configurator, in_rollback)
  File "/usr/share/vdsm/network/api.py", line 691, in _handleBondings
    destroyOnMasterRemoval='remove' in attrs)
  File "/usr/share/vdsm/network/models.py", line 280, in objectivize
    mtu, _netinfo)
  File "/usr/share/vdsm/network/models.py", line 269, in _objectivizeSlaves
    (nic, nicVlans or nicNet or nicBond))
ConfigNetworkError: (24, u'nic dummy_31 already used by bond0')
Comment 1 Martin Mucha 2015-11-19 03:49 EST
Created attachment 1096546 [details]
zipped supervdsm.log
Comment 2 Dan Kenigsberg 2015-11-19 08:37:36 EST

*** This bug has been marked as a duplicate of bug 1283528 ***

Note You need to log in before you can comment on or make changes to this bug.