Bug 128356 - subversion should include psvn.el
Summary: subversion should include psvn.el
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: subversion (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Joe Orton
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-07-22 02:23 UTC by Jens Petersen
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version: 1.0.6-3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-29 18:46:18 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jens Petersen 2004-07-22 02:23:37 UTC
Description of problem:
The subversion source includes a very useful elisp package
"contrib/client-side/psvn/psvn.el" which I think
it would be nice to include in our subversion package.

Additional info:
It could at least be included in the doc dir,
so that people who want to use can pull it over into their
elisp dirs.  Of course it would be nicer to add a -emacs and
perhaps even a -xemacs subpackage to host it in, so that it
just worked out of the box.

Comment 1 Joe Orton 2004-08-23 09:12:45 UTC
Where do I put the scripts for xemacs? What's the recommended
solution; an -emacs subpackage or not?  Or just own the common
directories twice and be damned?

/usr/share/emacs/site-lisp/psvn.el
/usr/share/xemacs/site-packages/lisp/psvn.el

is there a guide to use for packageres e.g. to how to get these
byte-compiled at build time?

Comment 2 Jens Petersen 2004-08-23 18:07:17 UTC
Well in this case I wouldn't worry about bytecompiling too much
and I would bother making -emacs/-xemacs subpackages either for this.
I think the locations you give are fine.

You may want to read https://bugzilla.fedora.us/show_bug.cgi?id=1880
where the same thing was down for xcscope.el in cscope...

It explains how you can use triggers to avoid dependencies on
emacs and xemacs, but you may feel it is too much engineering?

Comment 3 Joe Orton 2004-08-24 12:59:49 UTC
OK, thanks.  psvn.el is in both the above paths in 1.0.6-3; can you
confirm whether this works?

I used the psvn.el from the author's web site rather than the one in
the tarball, since the latter seemed to be a little out of date w.r.t
the former.

Comment 4 Jens Petersen 2004-09-29 18:46:18 UTC
Thanks a lot. :-)

At some point it will probably be nice to add an init file
so that psvn gets autoloaded for say svn-status.  But I can
file another report about that when I get tired of loading
it by hand. :)


Note You need to log in before you can comment on or make changes to this bug.