Bug 1283571 - C&U collection logs exceptions to evm.log
C&U collection logs exceptions to evm.log
Status: CLOSED WORKSFORME
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: C&U Capacity and Utilization (Show other bugs)
5.5.0
Unspecified Unspecified
unspecified Severity medium
: GA
: cfme-future
Assigned To: James Wong
Nandini Chandra
c&u
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-19 05:29 EST by Martin Povolny
Modified: 2017-04-19 10:19 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-04-19 10:19:06 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Martin Povolny 2015-11-19 05:29:52 EST
Description of problem:

Trying collect data for C&U on an appliance I am seeing this in the logs:

[----] E, [2015-11-19T05:24:42.103233 #19283:fe3990] ERROR -- : MIQ(MiqQueue#deliver) Message id: [58838], Error: [Association named 'hosts' was not found on MiqRegion; perhaps you misspelle
d it?]
[----] E, [2015-11-19T05:24:42.103480 #19283:fe3990] ERROR -- : [ActiveRecord::AssociationNotFoundError]: Association named 'hosts' was not found on MiqRegion; perhaps you misspelled it?  Me
thod:[rescue in deliver]
[----] E, [2015-11-19T05:24:42.103642 #19283:fe3990] ERROR -- : /opt/rh/cfme-gemset/bundler/gems/rails-8f6ee25ebb3b/activerecord/lib/active_record/associations.rb:161:in `association'
/opt/rh/cfme-gemset/bundler/gems/rails-8f6ee25ebb3b/activerecord/lib/active_record/associations/builder/collection_association.rb:66:in `host_ids'
/var/www/miq/vmdb/app/models/mixins/aggregation_mixin.rb:107:in `aggregate_hardware'
/var/www/miq/vmdb/app/models/mixins/aggregation_mixin.rb:35:in `aggregate_cpu_speed'
/var/www/miq/vmdb/app/models/vim_performance_state.rb:131:in `capture_total'
/var/www/miq/vmdb/app/models/vim_performance_state.rb:60:in `capture'
/var/www/miq/vmdb/app/models/metric/ci_mixin/capture.rb:209:in `perf_capture_state'
/var/www/miq/vmdb/app/models/metric/ci_mixin/state_finders.rb:21:in `vim_performance_state_for_ts'
/var/www/miq/vmdb/app/models/metric/ci_mixin/state_finders.rb:41:in `ext_management_systems_from_vim_performance_state_for_ts'
/var/www/miq/vmdb/app/models/metric/rollup.rb:189:in `rollup_child_metrics'
/var/www/miq/vmdb/app/models/metric/rollup.rb:131:in `block in rollup_hourly'
/var/www/miq/vmdb/app/models/metric/rollup.rb:131:in `each'
/var/www/miq/vmdb/app/models/metric/rollup.rb:131:in `rollup_hourly'
/var/www/miq/vmdb/app/models/metric/ci_mixin/rollup.rb:91:in `block (2 levels) in perf_rollup'
/var/www/miq/vmdb/gems/pending/util/extensions/miq-benchmark.rb:11:in `realtime_store'
/var/www/miq/vmdb/gems/pending/util/extensions/miq-benchmark.rb:30:in `realtime_block'
/var/www/miq/vmdb/app/models/metric/ci_mixin/rollup.rb:90:in `block in perf_rollup'
/var/www/miq/vmdb/gems/pending/util/extensions/miq-benchmark.rb:11:in `realtime_store'
/var/www/miq/vmdb/gems/pending/util/extensions/miq-benchmark.rb:30:in `realtime_block'
/var/www/miq/vmdb/app/models/metric/ci_mixin/rollup.rb:77:in `perf_rollup'
/var/www/miq/vmdb/app/models/miq_queue.rb:345:in `block in deliver'
/opt/rh/rh-ruby22/root/usr/share/ruby/timeout.rb:89:in `block in timeout'
/opt/rh/rh-ruby22/root/usr/share/ruby/timeout.rb:34:in `block in catch'
/opt/rh/rh-ruby22/root/usr/share/ruby/timeout.rb:34:in `catch'
/opt/rh/rh-ruby22/root/usr/share/ruby/timeout.rb:34:in `catch'
/opt/rh/rh-ruby22/root/usr/share/ruby/timeout.rb:104:in `timeout'
/var/www/miq/vmdb/app/models/miq_queue.rb:341:in `deliver'



Version-Release number of selected component (if applicable):
5.5.

How reproducible:


Steps to Reproduce:
1. Enable C&U collection
2. wait
3. read logs

Actual results:
stacktrace in the logs, no or limited C&U data collected

Expected results:
no errors, C&U data fully available

Additional info:
at least for the next 24 hours the appliance is running at 10.16.5.170
Comment 2 Martin Povolny 2015-11-19 05:44:02 EST
Looking at upstream, this might be fixed by a56b23a5. Verifying...
Comment 3 Martin Povolny 2015-11-19 05:58:46 EST
No the issue is still there with a56b23a5 applied.
Comment 5 James Wong 2017-04-19 10:19:06 EDT
Cannot reproduce this. Closing it.

Note You need to log in before you can comment on or make changes to this bug.