Bug 1283590 - Reduce the memory consumption of the basic test
Reduce the memory consumption of the basic test
Status: CLOSED CURRENTRELEASE
Product: ovirt-system-tests
Classification: Community
Component: RFEs (Show other bugs)
0.4
Unspecified Unspecified
unspecified Severity medium
: milestone3
: 0.5
Assigned To: David Caro
Pavel Stehlik
: Improvement
Depends On:
Blocks: 1278500
  Show dependency treegraph
 
Reported: 2015-11-19 06:17 EST by Anatoly Litovsky
Modified: 2016-09-26 17:55 EDT (History)
3 users (show)

See Also:
Fixed In Version: 0.5
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-17 07:40:15 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
vdsm log (36.32 KB, application/x-xz)
2015-11-24 07:10 EST, Yaniv Kaul
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 48822 master MERGED Lowered requirements Never
oVirt gerrit 49189 master MERGED Lowered vm_template mem to 512 MB Never

  None (edit)
Description Anatoly Litovsky 2015-11-19 06:17:56 EST
Current basic test runs 7 VMs with 16GB RAM each
this is overloading even high end laptops that we use

Lets assign :
4G for engine and hypervisor
2G for the storage controllers
reduce the hypervisors to 2
Comment 1 David Caro 2015-11-24 05:32:16 EST
The problem seems to still be happening, it seems it tries to spin up a vm with 4G in the host (and of course, failing to)
Comment 2 Yaniv Kaul 2015-11-24 07:10 EST
Created attachment 1098161 [details]
vdsm log
Comment 3 Yaniv Kaul 2015-11-24 07:11:22 EST
Relevant VDSM log entry:
Thread-112::DEBUG::2015-11-24 03:43:36,194::vm::3313::vm.Vm::(_run) vmId=`8d11c321-4b35-48df-bd5e-751d0182456b`::<?xml version="1.0" encoding="utf-8"?>
<domain type="kvm">
        <name>vm1</name>
        <uuid>8d11c321-4b35-48df-bd5e-751d0182456b</uuid>
        <memory>4194304</memory>
        <currentMemory>4194304</currentMemory>


(and I indeed can see in libvirt log that it failed running it).
Comment 4 David Caro 2015-11-24 07:13:48 EST
Failed also on jenkins
http://jenkins.ovirt.org/job/ovirt_3.5_system-tests/31/consoleFull
Comment 5 David Caro 2015-11-24 07:22:24 EST
Sorry, that job fails for different reasons (though the lago log is the same)
Comment 6 Yaniv Kaul 2015-11-24 07:51:57 EST
I assume the bug is in:
147         memory=4 * GB,
@ ovirt-system-tests/basic_suite_3.5/test-scenarios/004_basic_sanity.py
Comment 7 David Caro 2015-11-24 07:53:09 EST
that looks like it yes

Note You need to log in before you can comment on or make changes to this bug.