Bug 1283595 - rpc_clnt: client process crashed at emancipate (ctx=0x0, ret=-1) at glusterfsd/src/glusterfsd.c:1329
rpc_clnt: client process crashed at emancipate (ctx=0x0, ret=-1) at glusterfs...
Status: CLOSED DUPLICATE of bug 1269696
Product: GlusterFS
Classification: Community
Component: rpc (Show other bugs)
mainline
Unspecified Unspecified
urgent Severity urgent
: ---
: ---
Assigned To: bugs@gluster.org
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-19 06:27 EST by Vijaikumar Mallikarjuna
Modified: 2016-05-11 18:48 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-19 08:15:08 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
coredump and binaries of the failed regression test (13.69 MB, application/x-bzip)
2015-11-19 06:53 EST, Niels de Vos
no flags Details

  None (edit)
Description Vijaikumar Mallikarjuna 2015-11-19 06:27:42 EST
client process crashed when running regression test-case: './tests/bugs/glusterd/bug-1242882-do-not-pass-volinfo-quota.t'

from: https://build.gluster.org/job/rackspace-regression-2GB-triggered/15936/consoleFull

Manually triggered by user ndevos for Gerrit: http://review.gluster.org/12645 in silent mode.
Building remotely on slave23.cloud.gluster.org (smoke_tests rackspace_regression_2gb glusterfs-devrpms) in workspace /home/jenkins/root/workspace/rackspace-regression-2GB-triggered
 > git rev-parse --is-inside-work-tree # timeout=10
Fetching changes from the remote Git repository
 > git config remote.origin.url git://review.gluster.org/glusterfs.git # timeout=10
Fetching upstream changes from git://review.gluster.org/glusterfs.git
 > git --version # timeout=10
 > git -c core.askpass=true fetch --tags --progress git://review.gluster.org/glusterfs.git refs/changes/45/12645/1
 > git rev-parse bf83d5410550394e6c5fb5bbb2ac4393e447ab02^{commit} # timeout=10
Checking out Revision bf83d5410550394e6c5fb5bbb2ac4393e447ab02 (master)
 > git config core.sparsecheckout # timeout=10
 > git checkout -f bf83d5410550394e6c5fb5bbb2ac4393e447ab02
 > git rev-parse FETCH_HEAD^{commit} # timeout=10
 > git rev-list 6cc7ac4e2f29562953caa477a0ecd715977e1e16 # timeout=10
 > git tag -a -f -m Jenkins Build #15936 jenkins-rackspace-regression-2GB-triggered-15936 # timeout=10
[rackspace-regression-2GB-triggered] $ /bin/bash /tmp/hudson4182015431241941312.sh
....
....

./tests/bugs/glusterd/bug-1242882-do-not-pass-volinfo-quota.t: 1 new core files
+ RET=2
++ ls -l /core.28693
++ wc -l
+ cur_count=1
+ '[' 1 '!=' 0 ']'
+ mkdir -p /build/install/cores
+ mv /core.28693 /build/install/cores
+ filename=archived_builds/build-install-20151119:08:12:19.tar


stack-trace:
warning: Expected absolute pathname for libpthread in the inferior, but got ./lib64/libpthread.so.0.
warning: Unable to find libthread_db matching inferior's thread library, thread debugging will not be available.
warning: Expected absolute pathname for libpthread in the inferior, but got ./lib64/libpthread.so.0.
warning: Unable to find libthread_db matching inferior's thread library, thread debugging will not be available.
Core was generated by `/build/install/sbin/glusterfsd -s slave23.cloud.gluster.org --volfile-id patchy'.
Program terminated with signal SIGSEGV, Segmentation fault.
#0  0x0000000000407eae in emancipate (ctx=0x0, ret=-1) at /home/jenkins/root/workspace/rackspace-regression-2GB-triggered/glusterfsd/src/glusterfsd.c:1329
1329	/home/jenkins/root/workspace/rackspace-regression-2GB-triggered/glusterfsd/src/glusterfsd.c: No such file or directory.
(gdb) bt
#0  0x0000000000407eae in emancipate (ctx=0x0, ret=-1) at /home/jenkins/root/workspace/rackspace-regression-2GB-triggered/glusterfsd/src/glusterfsd.c:1329
#1  0x000000000040f806 in mgmt_pmap_signin_cbk (req=0x7fe5e407027c, iov=0x7fe5eb68d5d0, count=1, myframe=0x7fe5e406f26c) at /home/jenkins/root/workspace/rackspace-regression-2GB-triggered/glusterfsd/src/glusterfsd-mgmt.c:2174
#2  0x00007fe5f74c674b in saved_frames_unwind (saved_frames=0x1819fd0) at /home/jenkins/root/workspace/rackspace-regression-2GB-triggered/rpc/rpc-lib/src/rpc-clnt.c:366
#3  0x00007fe5f74c67ea in saved_frames_destroy (frames=0x1819fd0) at /home/jenkins/root/workspace/rackspace-regression-2GB-triggered/rpc/rpc-lib/src/rpc-clnt.c:383
#4  0x00007fe5f74c6c41 in rpc_clnt_connection_cleanup (conn=0x1818b80) at /home/jenkins/root/workspace/rackspace-regression-2GB-triggered/rpc/rpc-lib/src/rpc-clnt.c:532
#5  0x00007fe5f74c76cb in rpc_clnt_notify (trans=0x1818fd0, mydata=0x1818b80, event=RPC_TRANSPORT_DISCONNECT, data=0x1818fd0) at /home/jenkins/root/workspace/rackspace-regression-2GB-triggered/rpc/rpc-lib/src/rpc-clnt.c:854
#6  0x00007fe5f74c3b76 in rpc_transport_notify (this=0x1818fd0, event=RPC_TRANSPORT_DISCONNECT, data=0x1818fd0) at /home/jenkins/root/workspace/rackspace-regression-2GB-triggered/rpc/rpc-lib/src/rpc-transport.c:546
#7  0x00007fe5eccb1621 in socket_event_poll_err (this=0x1818fd0) at /home/jenkins/root/workspace/rackspace-regression-2GB-triggered/rpc/rpc-transport/socket/src/socket.c:1151
#8  0x00007fe5eccb634c in socket_event_handler (fd=9, idx=1, data=0x1818fd0, poll_in=1, poll_out=0, poll_err=24) at /home/jenkins/root/workspace/rackspace-regression-2GB-triggered/rpc/rpc-transport/socket/src/socket.c:2356
#9  0x00007fe5f7777804 in event_dispatch_epoll_handler (event_pool=0x17dec90, event=0x7fe5eb68de70) at /home/jenkins/root/workspace/rackspace-regression-2GB-triggered/libglusterfs/src/event-epoll.c:575
#10 0x00007fe5f7777bf2 in event_dispatch_epoll_worker (data=0x181a1a0) at /home/jenkins/root/workspace/rackspace-regression-2GB-triggered/libglusterfs/src/event-epoll.c:678
#11 0x00007fe5f69dea51 in start_thread () from ./lib64/libpthread.so.0
#12 0x00007fe5f634893d in clone () from ./lib64/libc.so.6
(gdb) list
1324	in /home/jenkins/root/workspace/rackspace-regression-2GB-triggered/glusterfsd/src/glusterfsd.c
(gdb)
Comment 1 Niels de Vos 2015-11-19 06:53 EST
Created attachment 1096630 [details]
coredump and binaries of the failed regression test

An other occurrence in https://build.gluster.org/job/rackspace-regression-2GB-triggered/15941/consoleFull :

    ./tests/bugs/glusterd/bug-913555.t: 1 new core files
Comment 2 Niels de Vos 2015-11-19 07:01:56 EST
Multiple regression failures today due to this. Marking as urgent.
Comment 3 Anand Nekkunti 2015-11-19 07:55:11 EST
http://review.gluster.org/#/c/12311/2 fixes this issue.
Comment 4 Anand Nekkunti 2015-11-19 08:04:09 EST
upstream patch is merged so moving to modified state.


http://review.gluster.org/#/c/12312/ is for 3.7
Comment 5 Niels de Vos 2015-11-19 08:15:08 EST
Seems that bug 1269696 is used for sending the fix to the master branch.

*** This bug has been marked as a duplicate of bug 1269696 ***

Note You need to log in before you can comment on or make changes to this bug.