Bug 1283596 - [abrt] systemd: skip(): systemd-journald killed by SIGABRT
[abrt] systemd: skip(): systemd-journald killed by SIGABRT
Status: CLOSED DUPLICATE of bug 1300212
Product: Fedora
Classification: Fedora
Component: systemd (Show other bugs)
23
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: systemd-maint
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:b0d7bef117be63ac0041dc758f0...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-19 06:29 EST by Juan Orti
Modified: 2016-01-20 05:35 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-20 05:35:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (15.43 KB, text/plain)
2015-11-19 06:29 EST, Juan Orti
no flags Details
File: cgroup (212 bytes, text/plain)
2015-11-19 06:29 EST, Juan Orti
no flags Details
File: core_backtrace (2.94 KB, text/plain)
2015-11-19 06:29 EST, Juan Orti
no flags Details
File: dso_list (1.15 KB, text/plain)
2015-11-19 06:29 EST, Juan Orti
no flags Details
File: environ (288 bytes, text/plain)
2015-11-19 06:29 EST, Juan Orti
no flags Details
File: limits (1.29 KB, text/plain)
2015-11-19 06:29 EST, Juan Orti
no flags Details
File: maps (8.69 KB, text/plain)
2015-11-19 06:29 EST, Juan Orti
no flags Details
File: mountinfo (3.72 KB, text/plain)
2015-11-19 06:29 EST, Juan Orti
no flags Details
File: open_fds (14.91 KB, text/plain)
2015-11-19 06:29 EST, Juan Orti
no flags Details
File: proc_pid_status (976 bytes, text/plain)
2015-11-19 06:29 EST, Juan Orti
no flags Details

  None (edit)
Description Juan Orti 2015-11-19 06:29:36 EST
Version-Release number of selected component:
systemd-222-8.fc23

Additional info:
reporter:       libreport-2.6.3
backtrace_rating: 4
cmdline:        /usr/lib/systemd/systemd-journald
crash_function: skip
executable:     /usr/lib/systemd/systemd-journald
global_pid:     844
kernel:         4.2.5-300.fc23.x86_64
runlevel:       N 5
type:           CCpp
uid:            0

Truncated backtrace:
Thread no. 1 (10 frames)
 #0 skip at getttyent.c:157
 #1 journal_file_post_change at src/journal/journal-file.c:1391
 #2 journal_file_append_entry.constprop.111 at src/journal/journal-file.c:1460
 #3 write_to_journal at src/journal/journald-server.c:513
 #4 dispatch_message_real.lto_priv.238 at src/journal/journald-server.c:820
 #5 server_dispatch_message at src/journal/journald-server.c:918
 #6 process_audit_string.lto_priv.231 at src/journal/journald-audit.c:414
 #7 server_process_audit_message at src/journal/journald-audit.c:468
 #8 server_process_datagram at src/journal/journald-server.c:1218
 #9 source_dispatch.lto_priv.250 at src/libsystemd/sd-event/sd-event.c:2117
Comment 1 Juan Orti 2015-11-19 06:29:43 EST
Created attachment 1096606 [details]
File: backtrace
Comment 2 Juan Orti 2015-11-19 06:29:44 EST
Created attachment 1096607 [details]
File: cgroup
Comment 3 Juan Orti 2015-11-19 06:29:46 EST
Created attachment 1096608 [details]
File: core_backtrace
Comment 4 Juan Orti 2015-11-19 06:29:48 EST
Created attachment 1096609 [details]
File: dso_list
Comment 5 Juan Orti 2015-11-19 06:29:49 EST
Created attachment 1096610 [details]
File: environ
Comment 6 Juan Orti 2015-11-19 06:29:51 EST
Created attachment 1096611 [details]
File: limits
Comment 7 Juan Orti 2015-11-19 06:29:52 EST
Created attachment 1096612 [details]
File: maps
Comment 8 Juan Orti 2015-11-19 06:29:54 EST
Created attachment 1096613 [details]
File: mountinfo
Comment 9 Juan Orti 2015-11-19 06:29:55 EST
Created attachment 1096614 [details]
File: open_fds
Comment 10 Juan Orti 2015-11-19 06:29:57 EST
Created attachment 1096615 [details]
File: proc_pid_status
Comment 11 Michal Sekletar 2015-11-20 03:48:48 EST
This crash did not happen because of hitting assertion in code, rather systemd killed (by sending SIGABRT) journald because watchdog timeout. I will increase watchdog timeout on systemd services in Fedora to 3min. Patch for this landed upstream some time ago.
Comment 12 Jan Synacek 2016-01-20 05:35:12 EST

*** This bug has been marked as a duplicate of bug 1300212 ***

Note You need to log in before you can comment on or make changes to this bug.