Bug 1283597 - upgrade vdsm-python-4.16.29-1 to vdsm-4.17.10.1-0 fails, because of passwd module
upgrade vdsm-python-4.16.29-1 to vdsm-4.17.10.1-0 fails, because of passwd mo...
Status: CLOSED CURRENTRELEASE
Product: vdsm
Classification: oVirt
Component: Tools (Show other bugs)
4.17.10
Unspecified Unspecified
urgent Severity urgent (vote)
: ovirt-3.6.1
: 4.17.11
Assigned To: Yaniv Bronhaim
Ondra Machacek
infra
:
Depends On:
Blocks: RHEV3.6Upgrade
  Show dependency treegraph
 
Reported: 2015-11-19 06:30 EST by Ondra Machacek
Modified: 2016-02-10 14:26 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-16 07:17:52 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
gklein: ovirt‑3.6.z?
gklein: blocker?
rule-engine: planning_ack?
danken: devel_ack+
rule-engine: testing_ack+


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 48222 None None None Never

  None (edit)
Description Ondra Machacek 2015-11-19 06:30:50 EST
Description of problem:
Upgrade on latest rhel 7.2 vdsm-python-4.16.29-1.el7ev.noarch to vdsm-4.17.10.1-0.el7ev.noarch fails , because of passwd module.

From syslog:
Nov 19 10:32:02 cheetah01 vdsmd_init_common.sh: Modules passwd, configfile are not configured

I can see that in host there is:
/usr/sbin/sasldblistusers2 -f /etc/libvirt/passwd.db
vdsm@rhevh

but from what I understand vdsm-4.17.10.1 checks for vdsm@ovirt.

Version-Release number of selected component (if applicable):
vdsm-python-4.16.29-1.el7ev.noarch

How reproducible:
always

Steps to Reproduce:
1. Install vdsm-python-4.16.29-1
2. Upgrade to vdsm-4.17.10.1-0

Actual results:
Fail:
Modules passwd, configfile are not configured

Expected results:
Success

Additional info:
Comment 1 Ondra Machacek 2015-11-19 08:07:08 EST
Also note - The only way I could reproduce, is from 3.6 engine via UpgradeManager feature. I couldn't reproduce with 3.5 engine and 'reinstall' feature. Could be related to issue.
Comment 2 Jiri Belka 2015-11-19 08:15:54 EST
(In reply to Ondra Machacek from comment #1)
> Also note - The only way I could reproduce, is from 3.6 engine via
> UpgradeManager feature. I couldn't reproduce with 3.5 engine and 'reinstall'
> feature. Could be related to issue.

Upgrade Manager feature is wide description - did you mean clicking on 'Upgrade' button and later on submitting the dialog?
Comment 3 Jiri Belka 2015-11-19 08:17:41 EST
IIUC the host had to be in 3.5 cluster level cluster in 3.6 engine as vdsm-4.16 is for RHEL 6. Am I right?
Comment 4 Ondra Machacek 2015-11-19 08:23:32 EST
(In reply to Jiri Belka from comment #2)
> Upgrade Manager feature is wide description - did you mean clicking on
> 'Upgrade' button and later on submitting the dialog?

Yes. Just hit upgrade button and wait for fail.

(In reply to Jiri Belka from comment #3)
> IIUC the host had to be in 3.5 cluster level cluster in 3.6 engine as
> vdsm-4.16 is for RHEL 6. Am I right?

The cluster is 3.5. Engine is 3.6. And host is latest el7.
Comment 5 Dan Kenigsberg 2015-11-19 08:49:05 EST
I believe that v4.17.10-20-g365b214 https://gerrit.ovirt.org/48222
(still unbuilt) solves this bug.
Comment 6 Ondra Machacek 2015-11-26 05:48:13 EST
I don't know the release process of vdsm, but I believe, this should be ON_QA, as vdsm-4.17.11-0.el7ev.noarch provides bug fix, no?
Comment 7 Jiri Belka 2015-11-26 09:12:37 EST
>> > Upgrade Manager feature is wide description - did you mean clicking on
>> > 'Upgrade' button and later on submitting the dialog?
>> 
>> Yes. Just hit upgrade button and wait for fail.
>>
>> [..]
>> 
>> The cluster is 3.5. Engine is 3.6. And host is latest el7.

> I believe that v4.17.10-20-g365b214 https://gerrit.ovirt.org/48222
> (still unbuilt) solves this bug.

I could not reproduce with 'Upgrade' button for a RHEL 7.2 host with vdsm-4.16.30-1.el7ev.x86_64, it upgraded successfully to vdsm-4.17.11-0.el7ev.noarch (host part of 3.5 cluster in rhevm-3.6.1-0.2.el6.noarch engine).
Comment 8 Dan Kenigsberg 2015-11-26 12:00:29 EST
(In reply to Ondra Machacek from comment #6)
> I don't know the release process of vdsm, but I believe, this should be
> ON_QA, as vdsm-4.17.11-0.el7ev.noarch provides bug fix, no?

Correct.
Comment 9 Ondra Machacek 2015-12-10 04:53:29 EST
Upgrade from vdsm-4.16.30-1.el7ev to vdsm-4.17.12-0.el7ev succeed.
Comment 10 Sandro Bonazzola 2015-12-16 07:17:52 EST
According to verification status and target milestone this issue should be fixed in oVirt 3.6.1. Closing current release.

Note You need to log in before you can comment on or make changes to this bug.