Bug 12836 - upgrade to 6.2 corrupts RPM database
upgrade to 6.2 corrupts RPM database
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
6.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Brock Organ
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-06-22 20:31 EDT by redhat-bugzilla
Modified: 2007-04-18 12:27 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-08-16 17:22:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description redhat-bugzilla 2000-06-22 20:31:25 EDT
I ran an upgrade from a Red Hat Linux 6.2 cdrom; along with filesystem
related problems, the rpm database is apparently fouled up. (bug 7631 is
another issue related to install and upgrade on this system.)

For example, /bin/ls: On the `upgraded' system now,

	$ rpm --qf /bin/ls
	fileutils-4.0-8

fileutils-4.0-8 is the fileutils from Red Hat 6.1.

	$ rpm -q --dump -p fileutils-4.0-21.i386.rpm | grep '/bin/ls'
	/bin/ls 43024 952479772 5ec59b9c05706b4ce65adf44d0d3ab24 0100755 root root
0 0 0 X
	
fileutils-4.0-21 is the fileutils from Red Hat 6.2. 

	$ md5sum /bin/ls
	5ec59b9c05706b4ce65adf44d0d3ab24  /bin/ls

/bin/ls on this system matches the /bin/ls from fileutils-4.0-21, but
the system rpm database still lists fileutils-4.0-8.

I'm not very familiar with the rpm database, but "rpm --rebuilddb" did
not change anything.
Comment 1 redhat-bugzilla 2000-06-26 06:25:14 EDT
When I noticed that my docbook tools weren't working, I noticed this:
I can't erase these packages, but I can't install them, either.

Something tells me that the rpm database isn't normalized. ;^)


[root@oud RPMS]# rpm --erase jade-1.2.1-9.i386.rpm jadetex-2.7-2.i386.rpm \
sgml-common-0.1-7.noarch.rpm sgml-tools-1.0.9-5.i386.rpm \
docbook-3.1-3.noarch.rpm stylesheets-0.13rh-4.noarch.rpm
error: package jade-1.2.1-9.i386.rpm is not installed
error: package jadetex-2.7-2.i386.rpm is not installed
error: package sgml-common-0.1-7.noarch.rpm is not installed
error: package sgml-tools-1.0.9-5.i386.rpm is not installed
error: package docbook-3.1-3.noarch.rpm is not installed
error: package stylesheets-0.13rh-4.noarch.rpm is not installed
[root@oud RPMS]# rpm --install jade-1.2.1-9.i386.rpm jadetex-2.7-2.i386.rpm \
sgml-common-0.1-7.noarch.rpm sgml-tools-1.0.9-5.i386.rpm \
docbook-3.1-3.noarch.rpm stylesheets-0.13rh-4.noarch.rpm \
package jade-1.2.1-9 is already installed
package jadetex-2.7-2 is already installed
package sgml-common-0.1-7 is already installed
package sgml-tools-1.0.9-5 is already installed
package docbook-3.1-3 is already installed
package stylesheets-0.13rh-4 is already installed
Comment 2 Brock Organ 2000-06-27 19:00:18 EDT
hmmm ... Using a stock 6.1 minimal install -> 6.2 upgrade (No package
customizations) I could not reproduce this ... :(

(ie after install ls is associated with the 6.2 package:

% rpm -qf /bin/ls
fileutils-4.0-21

)

Was your original 6.1 install a stock workstation or server install ...? If
custom, do you have the original package list ...?  Did you have any other
non-redhat 6.1 distribution packages installed ...?

Comment 3 Brock Organ 2000-08-16 17:22:16 EDT
I could not reproduce this problem in test ... please reopen this if it still
occurs regularly for you (and may not be a one time spurious event :) )

thanks for your report!

Note You need to log in before you can comment on or make changes to this bug.