Bug 1283604 - Error undefined method `build_script_grid' [miq_request/sort_template_grid] in sorting customize templates in requestinfo tab
Error undefined method `build_script_grid' [miq_request/sort_template_grid] i...
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS (Show other bugs)
5.5.0
Unspecified Unspecified
high Severity high
: GA
: 5.6.0
Assigned To: Martin Hradil
Aziza Karol
error:ui
:
Depends On:
Blocks: 1289250
  Show dependency treegraph
 
Reported: 2015-11-19 06:56 EST by Aziza Karol
Modified: 2016-06-29 11:03 EDT (History)
6 users (show)

See Also:
Fixed In Version: 5.6.0.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1289250 (view as bug list)
Environment:
Last Closed: 2016-06-29 11:03:13 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
sorting customize template (78.09 KB, image/png)
2015-11-19 06:56 EST, Aziza Karol
no flags Details
err (54.95 KB, image/png)
2015-11-19 06:57 EST, Aziza Karol
no flags Details

  None (edit)
Description Aziza Karol 2015-11-19 06:56:26 EST
Created attachment 1096632 [details]
sorting customize template

Description of problem:


Version-Release number of selected component (if applicable):
5.5.0.11-RC1

How reproducible:
100%

Steps to Reproduce:
1.Add a catalog item type of rhev pxe provisioning
2.In customize->request info tab do sorting for customize template 
3

Actual results:
 undefined method `build_script_grid' for #<MiqRequestController:0x00000012c19fc8> [miq_request/sort_template_grid]  displayed in UI. see attached screenshot.

Expected results:
should be able to sort

Additional info:
production.log:
[----] I, [2015-11-19T06:33:03.244658 #2982:12a9990]  INFO -- : Started POST "/miq_request/sort_template_grid/new?field_id=customize__customization_template_id&sort_choice=description" for 127.0.0.1 at 2015-11-19 06:33:03 -0500
[----] I, [2015-11-19T06:33:03.247435 #2982:12a9990]  INFO -- : Processing by MiqRequestController#sort_template_grid as JS
[----] I, [2015-11-19T06:33:03.247538 #2982:12a9990]  INFO -- :   Parameters: {"field_id"=>"customize__customization_template_id", "sort_choice"=>"description", "id"=>"new"}
[----] F, [2015-11-19T06:33:03.642859 #2982:12a9990] FATAL -- : Error caught: [NoMethodError] undefined method `build_script_grid' for #<MiqRequestController:0x0000001562af60>
/var/www/miq/vmdb/app/controllers/application_controller/miq_request_methods.rb:515:in `sort_grid'
/var/www/miq/vmdb/app/controllers/application_controller/miq_request_methods.rb:259:in `sort_template_grid'
/opt/rh/cfme-gemset/gems/actionpack-4.2.5/lib/action_controller/metal/implicit_render.rb:4:in `send_action'
/opt/rh/cfme-gemset/gems/actionpack-4.2.5/lib/abstract_controller/base.rb:198:in `process_action'
/opt/rh/cfme-gemset/gems/actionpack-4.2.5/lib/action_controller/metal/rendering.rb:10:in `process_action'
/opt/rh/cfme-gemset/gems/actionpack-4.2.5/lib/abstract_controller/callbacks.rb:20:in `block in process_action'
/opt/rh/cfme-gemset/gems/activesupport-4.2.5/lib/active_support/callbacks.rb:117:in `call'
/opt/rh/cfme-gemset/gems/activesupport-4.2.5/lib/active_support/callbacks.rb:117:in `call'
/opt/rh/cfme-gemset/gems/activesupport-4.2.5/lib/active_support/callbacks.rb:555:in `block (2 levels) in compile'
/opt/rh/cfme-gemset/gems/activesupport-4.2.5/lib/active_support/callbacks.rb:505:in `call'
/opt/rh/cfme-gemset/gems/activesupport-4.2.5/lib/active_support/callbacks.rb:505:in `call'
/opt/rh/cfme-gemset/gems/activesupport-4.2.5/lib/active_support/callbacks.rb:92:in `__run_callbacks__'
/opt/rh/cfme-gemset/gems/activesupport-4.2.5/lib/active_support/callbacks.rb:778:in `_run_process_action_callbacks'
/opt/rh/cfme-gemset/gems/activesupport-4.2.5/lib/active_support/callbacks.rb:81:in `run_callbacks'
/opt/rh/cfme-gemset/gems/actionpack-4.2.5/lib/abstract_controller/callbacks.rb:19:in `process_action'
/opt/rh/cfme-gemset/gems/actionpack-4.2.5/lib/action_controller/metal/rescue.rb:29:in `process_action'
/opt/rh/cfme-gemset/gems/actionpack-4.2.5/lib/action_controller/metal/instrumentation.rb:32:in `block in process_action'
/opt/rh/cfme-gemset/gems/activesupport-4.2.5/lib/active_support/notifications.rb:164:in `block in instrument'
/opt/rh/cfme-gemset/gems/activesupport-4.2.5/lib/active_support/notifications/instrumenter.rb:20:in `instrument'
/opt/rh/cfme-gemset/gems/activesupport-4.2.5/lib/active_support/notifications.rb:164:in `instrument'
/opt/rh/cfme-gemset/gems/actionpack-4.2.5/lib/action_controller/metal/instrumentation.rb:30:in `process_action'
/opt/rh/cfme-gemset/gems/actionpack-4.2.5/lib/action_controller/metal/params_wrapper.rb:250:in `process_action'
/opt/rh/cfme-gemset/gems/activerecord-4.2.5/lib/active_record/railties/controller_runtime.rb:18:in `process_action'
/opt/rh/cfme-gemset/gems/actionpack-4.2.5/lib/abstract_controller/base.rb:137:in `process'
/opt/rh/cfme-gemset/gems/actionview-4.2.5/lib/action_view/rendering.rb:30:in `process'
/opt/rh/cfme-gemset/gems/actionpack-4.2.5/lib/action_controller/metal.rb:196:in `dispatch'
/opt/rh/cfme-gemset/gems/actionpack-4.2.5/lib/action_controller/metal/rack_delegation.rb:13:in `dispatch'
/opt/rh/cfme-gemset/gems/actionpack-4.2.5/lib/action_controller/metal.rb:237:in `block in action'
/opt/rh/cfme-gemset/gems/actionpack-4.2.5/lib/action_dispatch/routing/route_set.rb:76:in `call'
/opt/rh/cfme-gemset/gems/actionpack-4.2.5/lib/action_dispatch/routing/route_set.rb:76:in `dispatch'
/opt/rh/cfme-gemset/gems/actionpack-4.2.5/lib/action_dispatch/routing/route_set.rb:45:in `serve'
/opt/rh/cfme-gemset/gems/actionpack-4.2.5/lib/action_dispatch/journey/router.rb:43:in `block in serve'
/opt/rh/cfme-gemset/gems/actionpack-4.2.5/lib/action_dispatch/journey/router.rb:30:in `each'
/opt/rh/cfme-gemset/gems/actionpack-4.2.5/lib/action_dispatch/journey/router.rb:30:in `serve'
/opt/rh/cfme-gemset/gems/actionpack-4.2.5/lib/action_dispatch/routing/route_set.rb:817:in `call'
/opt/rh/cfme-gemset/gems/rack-1.6.4/lib/rack/etag.rb:24:in `call'
/opt/rh/cfme-gemset/gems/rack-1.6.4/lib/rack/conditionalget.rb:38:in `call'
/opt/rh/cfme-gemset/gems/rack-1.6.4/lib/rack/head.rb:13:in `call'
/opt/rh/cfme-gemset/gems/actionpack-4.2.5/lib/action_dispatch/middleware/params_parser.rb:27:in `call'
/opt/rh/cfme-gemset/gems/actionpack-4.2.5/lib/action_dispatch/middleware/flash.rb:260:in `call'
/opt/rh/cfme-gemset/gems/rack-1.6.4/lib/rack/session/abstract/id.rb:225:in `context'
/opt/rh/cfme-gemset/gems/rack-1.6.4/lib/rack/session/abstract/id.rb:220:in `call'
/opt/rh/cfme-gemset/gems/actionpack-4.2.5/lib/action_dispatch/middleware/cookies.rb:560:in `call'
/opt/rh/cfme-gemset/gems/activerecord-4.2.5/lib/active_record/query_cache.rb:36:in `call'
/opt/rh/cfme-gemset/gems/activerecord-4.2.5/lib/active_record/connection_adapters/abstract/connection_pool.rb:653:in `call'
/opt/rh/cfme-gemset/gems/actionpack-4.2.5/lib/action_dispatch/middleware/callbacks.rb:29:in `block in call'
/opt/rh/cfme-gemset/gems/activesupport-4.2.5/lib/active_support/callbacks.rb:88:in `__run_callbacks__'
/opt/rh/cfme-gemset/gems/activesupport-4.2.5/lib/active_support/callbacks.rb:778:in `_run_call_callbacks'
/opt/rh/cfme-gemset/gems/activesupport-4.2.5/lib/active_support/callbacks.rb:81:in `run_callbacks'
/opt/rh/cfme-gemset/gems/actionpack-4.2.5/lib/action_dispatch/middleware/callbacks.rb:27:in `call'
/opt/rh/cfme-gemset/gems/actionpack-4.2.5/lib/action_dispatch/middleware/remote_ip.rb:78:in `call'
/opt/rh/cfme-gemset/gems/actionpack-4.2.5/lib/action_dispatch/middleware/debug_exceptions.rb:17:in `call'
/opt/rh/cfme-gemset/gems/actionpack-4.2.5/lib/action_dispatch/middleware/show_exceptions.rb:30:in `call'
/opt/rh/cfme-gemset/gems/railties-4.2.5/lib/rails/rack/logger.rb:38:in `call_app'
/opt/rh/cfme-gemset/gems/railties-4.2.5/lib/rails/rack/logger.rb:22:in `call'
/opt/rh/cfme-gemset/gems/actionpack-4.2.5/lib/action_dispatch/middleware/request_id.rb:21:in `call'
/opt/rh/cfme-gemset/gems/rack-1.6.4/lib/rack/methodoverride.rb:22:in `call'
/opt/rh/cfme-gemset/gems/rack-1.6.4/lib/rack/runtime.rb:18:in `call'
/opt/rh/cfme-gemset/gems/activesupport-4.2.5/lib/active_support/cache/strategy/local_cache_middleware.rb:28:in `call'
/opt/rh/cfme-gemset/gems/rack-1.6.4/lib/rack/lock.rb:17:in `call'
/opt/rh/cfme-gemset/gems/actionpack-4.2.5/lib/action_dispatch/middleware/static.rb:116:in `call'
/opt/rh/cfme-gemset/gems/actionpack-4.2.5/lib/action_dispatch/middleware/static.rb:116:in `call'
/opt/rh/cfme-gemset/gems/rack-1.6.4/lib/rack/sendfile.rb:113:in `call'
/opt/rh/cfme-gemset/gems/railties-4.2.5/lib/rails/engine.rb:518:in `call'
/opt/rh/cfme-gemset/gems/railties-4.2.5/lib/rails/application.rb:165:in `call'
/opt/rh/cfme-gemset/gems/rack-1.6.4/lib/rack/content_length.rb:15:in `call'
/opt/rh/rh-ruby22/root/usr/share/gems/gems/thin-1.6.3/lib/thin/connection.rb:86:in `block in pre_process'
/opt/rh/rh-ruby22/root/usr/share/gems/gems/thin-1.6.3/lib/thin/connection.rb:84:in `catch'
/opt/rh/rh-ruby22/root/usr/share/gems/gems/thin-1.6.3/lib/thin/connection.rb:84:in `pre_process'
/opt/rh/rh-ruby22/root/usr/share/gems/gems/thin-1.6.3/lib/thin/connection.rb:53:in `process'
/opt/rh/rh-ruby22/root/usr/share/gems/gems/thin-1.6.3/lib/thin/connection.rb:39:in `receive_data'
/opt/rh/rh-ruby22/root/usr/share/gems/gems/eventmachine-1.0.7/lib/eventmachine.rb:187:in `run_machine'
/opt/rh/rh-ruby22/root/usr/share/gems/gems/eventmachine-1.0.7/lib/eventmachine.rb:187:in `run'
/opt/rh/rh-ruby22/root/usr/share/gems/gems/thin-1.6.3/lib/thin/backends/base.rb:73:in `start'
/opt/rh/rh-ruby22/root/usr/share/gems/gems/thin-1.6.3/lib/thin/server.rb:162:in `start'
/opt/rh/cfme-gemset/gems/rack-1.6.4/lib/rack/handler/thin.rb:19:in `run'
/opt/rh/cfme-gemset/gems/rack-1.6.4/lib/rack/server.rb:286:in `start'
/opt/rh/cfme-gemset/gems/railties-4.2.5/lib/rails/commands/server.rb:80:in `start'
/opt/rh/cfme-gemset/gems/railties-4.2.5/lib/rails/commands/commands_tasks.rb:80:in `block in server'
/opt/rh/cfme-gemset/gems/railties-4.2.5/lib/rails/commands/commands_tasks.rb:75:in `tap'
/opt/rh/cfme-gemset/gems/railties-4.2.5/lib/rails/commands/commands_tasks.rb:75:in `server'
/opt/rh/cfme-gemset/gems/railties-4.2.5/lib/rails/commands/commands_tasks.rb:39:in `run_command!'
/opt/rh/cfme-gemset/gems/railties-4.2.5/lib/rails/commands.rb:17:in `<top (required)>'
/var/www/miq/vmdb/bin/rails:4:in `require'
/var/www/miq/vmdb/bin/rails:4:in `<main>'
Comment 1 Aziza Karol 2015-11-19 06:57 EST
Created attachment 1096633 [details]
err
Comment 3 Harpreet Kataria 2015-11-24 18:06:48 EST
Martin,

Looks like incorrect action is being sent up when sorting customization template list in provisioning form.

let me know if you have questions

~Harpreet
Comment 6 CFME Bot 2015-12-02 14:45:02 EST
New commit detected on ManageIQ/manageiq/master:
https://github.com/ManageIQ/manageiq/commit/76b0af2edea274f0be9c39b5051866af0729b9cd

commit 76b0af2edea274f0be9c39b5051866af0729b9cd
Author:     Martin Hradil <mhradil@redhat.com>
AuthorDate: Thu Nov 26 16:52:46 2015 +0000
Commit:     Martin Hradil <mhradil@redhat.com>
CommitDate: Thu Nov 26 16:52:46 2015 +0000

    MiqRequestMethods - sort_template_grid should call sort_grid('template', ...)
    
    There is no build_script_grid, no prov_script_div, etc.
    
    The other sort_*_grid allways pass the * to sort_grid, so should sort_template_grid.
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1283604

 app/controllers/application_controller/miq_request_methods.rb | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
Comment 7 CFME Bot 2015-12-07 16:08:37 EST
New commit detected on cfme/5.5.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=2e1ad15f29124a386148731db2958ed19460fee2

commit 2e1ad15f29124a386148731db2958ed19460fee2
Author:     Martin Hradil <mhradil@redhat.com>
AuthorDate: Thu Nov 26 16:52:46 2015 +0000
Commit:     Martin Hradil <mhradil@redhat.com>
CommitDate: Mon Nov 30 15:20:31 2015 +0000

    MiqRequestMethods - sort_template_grid should call sort_grid('template', ...)
    
    There is no build_script_grid, no prov_script_div, etc.
    
    The other sort_*_grid allways pass the * to sort_grid, so should sort_template_grid.
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1283604
    (cherry picked from commit 76b0af2edea274f0be9c39b5051866af0729b9cd)

 app/controllers/application_controller/miq_request_methods.rb | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
Comment 8 CFME Bot 2015-12-07 16:08:52 EST
New commit detected on cfme/5.5.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=e19a7927c42fc582283490b5bdb863ef03003aca

commit e19a7927c42fc582283490b5bdb863ef03003aca
Merge: f8e9c04 2e1ad15
Author:     Dan Clarizio <dclarizi@redhat.com>
AuthorDate: Mon Dec 7 16:05:19 2015 -0500
Commit:     Dan Clarizio <dclarizi@redhat.com>
CommitDate: Mon Dec 7 16:05:19 2015 -0500

    Merge branch 'bz1283604-script-grid-55' into '5.5.z'
    
    MiqRequestMethods - sort_template_grid should call sort_grid('template', ...)
    
    There is no build_script_grid, no prov_script_div, etc.
    
    The other sort_*_grid allways pass the * to sort_grid, so should sort_template_grid.
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1283604
    (cherry picked from commit 76b0af2edea274f0be9c39b5051866af0729b9cd)
    
    5.5 BZ: https://bugzilla.redhat.com/show_bug.cgi?id=1289250
    
    https://github.com/ManageIQ/manageiq/pull/5624
    clean cherry pick
    
    See merge request !550

 app/controllers/application_controller/miq_request_methods.rb | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
Comment 9 Aziza Karol 2016-05-05 05:42:30 EDT
No Error in sorting customize templates.

Verified:5.6.0.5-beta2.4.20160503153816_1fb554f
Comment 11 errata-xmlrpc 2016-06-29 11:03:13 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1348

Note You need to log in before you can comment on or make changes to this bug.