This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1283629 - When selecting a template in the provision dialog, the table jumps to the top hiding your selection
When selecting a template in the provision dialog, the table jumps to the top...
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS (Show other bugs)
5.5.0
Unspecified Unspecified
medium Severity medium
: GA
: 5.6.0
Assigned To: Harpreet Kataria
Shveta
ui:catalog
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-19 08:06 EST by Pete Savage
Modified: 2016-06-29 11:03 EDT (History)
7 users (show)

See Also:
Fixed In Version: 5.6.0.6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-06-29 11:03:19 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pete Savage 2015-11-19 08:06:04 EST
Description of problem: When selecting a template in the provision dialog, the table jumps to the top hiding your selection


Version-Release number of selected component (if applicable): 5.5.0.11


How reproducible: 100%


Steps to Reproduce:
1. Add a provider
2. Add a catalog item for the provider
3. Enter the Request Info tab
4. Scroll to a template near the bottom of the list and select it

Actual results: Table then jumps to top of list meaning you have to scroll down again to see what got selected.


Expected results: Table should remain where it was.


Additional info:
Comment 4 CFME Bot 2016-05-06 14:25:45 EDT
New commit detected on ManageIQ/manageiq/master:
https://github.com/ManageIQ/manageiq/commit/9ff5b2d18a1aad4283daaf0f17519d9375245a5a

commit 9ff5b2d18a1aad4283daaf0f17519d9375245a5a
Author:     Harpreet Kataria <hkataria@redhat.com>
AuthorDate: Fri May 6 10:57:24 2016 -0400
Commit:     Harpreet Kataria <hkataria@redhat.com>
CommitDate: Fri May 6 10:58:39 2016 -0400

    Added JS function to scroll to selected row in table.
    
    Changed all views on provisioning form to scroll to selected row in table when screen reloads after transaction is sent upto the server.
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1283629

 app/assets/javascripts/miq_application.js                    | 5 +++++
 app/views/miq_request/_prov_configured_system_grid.html.haml | 2 ++
 app/views/miq_request/_prov_ds_grid.html.haml                | 2 ++
 app/views/miq_request/_prov_host_grid.html.haml              | 2 ++
 app/views/miq_request/_prov_iso_img_grid.html.haml           | 2 ++
 app/views/miq_request/_prov_pxe_img_grid.html.haml           | 2 ++
 app/views/miq_request/_prov_template_grid.html.haml          | 2 ++
 app/views/miq_request/_prov_vc_grid.html.haml                | 2 ++
 app/views/miq_request/_prov_vm_grid.html.haml                | 5 +++++
 app/views/miq_request/_prov_windows_image_grid.html.haml     | 2 ++
 10 files changed, 26 insertions(+)
Comment 6 Shveta 2016-05-13 15:15:03 EDT
Fixed.
Verified in 5.6.0.6-beta2.5.20160511140943_ff75fb2
Comment 9 errata-xmlrpc 2016-06-29 11:03:19 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1348

Note You need to log in before you can comment on or make changes to this bug.