Bug 1283648 - Update cpupowerutils to upstream
Update cpupowerutils to upstream
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: cpupowerutils (Show other bugs)
6.8
Unspecified Linux
unspecified Severity unspecified
: rc
: ---
Assigned To: jtanenba
Erik Hamera
:
Depends On: 1298255
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-19 09:02 EST by jtanenba
Modified: 2017-06-14 10:49 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1298255 (view as bug list)
Environment:
Last Closed: 2016-05-10 16:29:13 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description jtanenba 2015-11-19 09:02:40 EST
Update cpupowerutils package to reflect most current upstream code
Comment 2 Erik Hamera 2016-03-03 23:23:33 EST
There is cpupower 2.6.32 from package cpupowerutils-1.3-1.el6.x86_64 in 6.8.

Is that updated enough? 

There is kernel 2.6.32-621.el6.x86_64, so yes I think.

On the other hand the newest code is cpupowerutils from kernel 4.2 obviously.
Comment 6 Erik Hamera 2016-03-10 11:32:41 EST
The question is - from my point of view - if we want to mix old kernel and new cpupowerutils. 

If it will work together, we can say, that the newer is better (less bugs and more features). But is proper functionality guaranteed/wanted from upstream?
If not, I'm inclining to use the same version like version of kernel is.
Comment 7 Erik Hamera 2016-03-23 23:07:39 EDT
Hi jtaneba,
is possible to use the newer cpupowerutils than kernel, or is right when versions of cpupowerutils and kernel are the same?
Comment 8 Erik Hamera 2016-04-06 21:39:55 EDT
No reply to my question in c7.

It seems, that the code in ftp://porkchop.devel.redhat.com/mnt/redhat/released/RHEL-6/6.8-Beta/Server/source/SRPMS/cpupowerutils-1.3-1.el6.src.rpm is the same as the code in https://www.kernel.org/pub/linux/utils/kernel/cpufreq/cpufrequtils-008.tar.xz .

Diff is pretty big (over 6k lines), but it changes formatting of code, content of printf()s and things like that mostly (no, I haven't read it character by character).

The newest file in upstream is from 7 Jun 2015 and last update in srpm's spec file is from 19 Jan 2016. 

Based on data available to me I think we have most current upstream code. If anyone think I'm wrong, prove it please and put this bug back to QE.
Comment 10 errata-xmlrpc 2016-05-10 16:29:13 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0785.html

Note You need to log in before you can comment on or make changes to this bug.