Bug 128365 - "wheel mouse" laptop touchpad not properly detected
"wheel mouse" laptop touchpad not properly detected
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Paul Nasrat
Mike McLean
Depends On: 116091
  Show dependency treegraph
Reported: 2004-07-22 01:52 EDT by Dee-Ann LeBlanc
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2004-09-22 15:52:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Dee-Ann LeBlanc 2004-07-22 01:52:06 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7)
Gecko/20040706 Firefox/0.9.1

Description of problem:
My emachine M5310 laptop has a touchpad for mousing that has a wheel
slider to the right, that acts as a wheel for a wheel mouse. However,
FC3Test1 sees the slider part as part of the rest of the touchpad, so
I don't get the wheel mouse ... I'm trying to find system-config-mouse
... hmmm, I have it installed but it's not available under main menu
-> System Settings, which it should be. Anyway, it's detecting a 3
Button Mouse (PS/2) when it should be finding a Wheel Mouse (PS/2).
Changing this over manually using system-config-mouse doesn't fix the
problem, it still doesn't see the "wheel" part.

I recall this working in FC1 so I know it's possible. :)

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Install FC3Test1 on laptop
2. No wheel mouse functionality
3. Open terminal window
4. Type system-config-mouse
5. Select Wheel Mouse (PS/2)
6. Add 3 button emulation
7. Save settings.
8. Still no wheel mouse
9. Close X down to runlevel 3
10. Type startx
11. Still no wheel mouse.

Actual Results:  No wheel mouse functionality.

Expected Results:  Wheel mouse functionality.

Additional info:
Comment 1 Paul Nasrat 2004-07-26 12:19:24 EDT
This is a 2.4/2.6 change in the input layer, I imagine it's not a
"real" wheel mouse but uses synaptics protocol on the wheel.

For completeness can you please attach the output of cat
/proc/bus/input /devices

The synaptics driver is going to be put in to FC3.  In addition you
can try booting with psmouse.proto=imps, that should give you tap
click at least.
Comment 2 Dee-Ann LeBlanc 2004-09-14 18:22:54 EDT
My apologies for taking a while on this, cat /proc/bus/input/devices

I: Bus=0011 Vendor=0002 Product=0007 Version=0000
N: Name="SynPS/2 Synaptics TouchPad"
P: Phys=isa0060/serio1/input0
H: Handlers=mouse0 event0
B: EV=b
B: KEY=6420 0 70000 0 0 0 0 0 0 0 0
B: ABS=11000003

I: Bus=0011 Vendor=0001 Product=0001 Version=ab41
N: Name="AT Translated Set 2 keyboard"
P: Phys=isa0060/serio0/input0
H: Handlers=kbd event1
B: EV=120003
B: KEY=4 2000000 3802078 f840d001 f2ffffdf ffefffff ffffffff fffffffe
B: LED=7

will now try your booting recommendation
Comment 3 Dee-Ann LeBlanc 2004-09-14 18:27:23 EDT
You are correct, I now have tap-click with that kernel option, thanks. :)
Comment 4 Jeremy Katz 2004-09-22 15:52:41 EDT
Should work with what's there now.

Note You need to log in before you can comment on or make changes to this bug.