Bug 1283650 - "logs" inspection collector can fail with UnicodeDecodeError
"logs" inspection collector can fail with UnicodeDecodeError
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-ironic-python-agent (Show other bugs)
8.0 (Liberty)
Unspecified Unspecified
urgent Severity unspecified
: ga
: 8.0 (Liberty)
Assigned To: Dmitry Tantsur
Raviv Bar-Tal
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-19 09:03 EST by Dmitry Tantsur
Modified: 2016-04-07 17:43 EDT (History)
7 users (show)

See Also:
Fixed In Version: openstack-ironic-python-agent-1.1.0-2.el7ost
Doc Type: Bug Fix
Doc Text:
Log processing in the introspection ramdisk did not take into account non-Latin characters in logs. Consequently, the "logs" collector failed during introspection. With this update, log processing has been fixed to properly handle any encoding.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-07 17:43:20 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 1517913 None None None Never
OpenStack gerrit 247514 None None None Never

  None (edit)
Description Dmitry Tantsur 2015-11-19 09:03:57 EST
Description of problem:
Logs collector in IPA fails with UnicodeDecodeError.

Steps to Reproduce:
1. Enable logs collector, prepend ipa-inspection-collectors=default,logs to the kernel command line in /httpboot/inspector.ipxe
2. Start introspection

Actual results:
Ramdisk will return "unable to decode symbol" error

Expected results:
Ramdisk logs are returned.
Comment 4 errata-xmlrpc 2016-04-07 17:43:20 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-0604.html

Note You need to log in before you can comment on or make changes to this bug.