Bug 1283653 - Use of ProxyErrorOverride causes slow response time for error status code (4xx)
Use of ProxyErrorOverride causes slow response time for error status code (4xx)
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: httpd (Show other bugs)
7.1
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Web Stack Team
Martin Frodl
:
Depends On:
Blocks: 1305230
  Show dependency treegraph
 
Reported: 2015-11-19 09:08 EST by Ingo Weiss
Modified: 2017-11-08 13:00 EST (History)
8 users (show)

See Also:
Fixed In Version: httpd-2.4.6-41.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-11-04 04:09:40 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Apache Bugzilla 53420 None None None Never
JBoss Issue Tracker JWS-183 Critical Verified Use of ProxyErrorOverride causes slow response time for error status code (4xx) 2017-11-28 13:26 EST
Red Hat Knowledge Base (Solution) 1487043 None None None 2016-06-07 12:02 EDT

  None (edit)
Description Ingo Weiss 2015-11-19 09:08:38 EST
Description of problem: It takes X seconds to respond to a request (where X = ProxyTimeout) when the response code is a 404 (or maybe any 4xx).


Version-Release number of selected component (if applicable): httpd-2.4.6-31.el7_1.1.x86_64


How reproducible: Always.


Steps to Reproduce:
1. Add the following configuration to your Apache:
   ProxyPass /sample/ http://localhost:8080/sample/
   ProxyPassReverse /sample/ http://localhost:8080/sample/
   ProxyErrorOverride On
   ProxyTimeout 10

2. Deploy the sample application in EAP. (I used EAP 6.4 and deployed https://tomcat.apache.org/tomcat-7.0-doc/appdev/sample/sample.war) 

3. Try to load a URL that will cause 404 from backend. I used http://jws3/sample/hellonothing.jsp to reproduce.

Actual results:
When you navigate to URL that triggers 404, you must wait for 10 seconds to go by before seeing 404 page. (10 seconds because that is what ProxyTimeout is set to)


Expected results: I would expect an immediate return of 404 page because the proxy is responding very quickly with a 404. 


Additional info:
I used the same setup as described in Reproduction section but used RHEL 6.7's httpd 2.2.15, which does not behave like this.
Comment 3 JBoss JIRA Server 2015-12-17 06:00:48 EST
Michal Karm Babacek <mbabacek@redhat.com> updated the status of jira JWS-183 to Coding In Progress
Comment 4 JBoss JIRA Server 2015-12-17 06:08:58 EST
Michal Karm Babacek <mbabacek@redhat.com> updated the status of jira JWS-183 to Resolved
Comment 5 JBoss JIRA Server 2015-12-17 06:13:22 EST
Michal Karm Babacek <mbabacek@redhat.com> updated the status of jira JWS-183 to Coding In Progress
Comment 6 JBoss JIRA Server 2015-12-17 06:13:28 EST
Michal Karm Babacek <mbabacek@redhat.com> updated the status of jira JWS-183 to Resolved
Comment 7 Michal Karm Babacek 2015-12-17 06:17:30 EST
See http://red.ht/1JdK1Tp
Comment 8 JBoss JIRA Server 2016-01-21 08:50:40 EST
Bogdan Sikora <bsikora@redhat.com> updated the status of jira JWS-183 to Reopened
Comment 9 JBoss JIRA Server 2016-02-10 02:25:23 EST
Michal Karm Babacek <mbabacek@redhat.com> updated the status of jira JWS-183 to Resolved
Comment 15 errata-xmlrpc 2016-11-04 04:09:40 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-2534.html

Note You need to log in before you can comment on or make changes to this bug.