Bug 1283666 - [f23] kvm doesn't work on some hardware
[f23] kvm doesn't work on some hardware
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-19 09:27 EST by Dusty Mabe
Modified: 2016-10-03 09:31 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-10-03 09:31:45 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dusty Mabe 2015-11-19 09:27:07 EST
Description of problem:

Running qemu-kvm (and thus libvirt/kvm) just hangs with no activity on some hardware. Right now the only affected hardware that we have noticed this on some Intel Xeon based processors (These are the Fedora build hosts and thus they can no longer run ImageFactory to build images).

Here is reproducer and a list of hardware and success/failure:

Steps to try to reproduce issue:

1. cd /root/
2. wget http://download.cirros-cloud.net/0.3.4/cirros-0.3.4-x86_64-disk.img
3. /usr/bin/qemu-kvm -m 1024 -name f15 -drive file=/root/cirros-0.3.4-x86_64-disk.img,if=virtio -nographic

IT IS A SUCCESS IF YOU SEE SERIAL CONSOLE OUTPUT
IT IS A FAILURE IF YOU SEE NO OUTPUT AND NOTHING HAPPENS

NOTE - to get out of qemu: ctrl-a c then type 'quit'

***RESULTS***

[dl160 server FAILURE]
model name      : Intel(R) Xeon(R) CPU           L5520  @ 2.27GHz
[root@cob-dl160 ~]# rpm -q kernel qemu-kvm
kernel-4.2.3-300.fc23.x86_64
kernel-4.2.5-300.fc23.x86_64
qemu-kvm-2.4.0.1-1.fc23.x86_64
# Tried with newer and older kernel

[IBM Product Name: BladeCenter HS22 -[7870AC1]- FAILURE]
model name      : Intel(R) Xeon(R) CPU           E5540  @ 2.53GHz
kernel-4.2.5-300.fc23.x86_64
qemu-kvm-2.4.1-1.fc23.x86_64

[ibm x3250 m4 SUCCESS]
Intel(R) Xeon(R) CPU E3-1220 V2 @ 3.10GHz]
kernel-4.2.5-300.fc23.x86_64
qemu-kvm-2.4.1-1.fc23.x86_64

[Lenovo laptop Success]
model name    : Intel(R) Core(TM) i7-3520M CPU @ 2.90GHz
[root@hattop ~]# rpm -q kernel qemu-kvm
kernel-4.2.3-300.fc23.x86_64
qemu-kvm-2.4.0.1-1.fc23.x86_64

[Dell server success]
model name      : Six-Core AMD Opteron(tm) Processor 2419 EE
[root@cob-dell9 ~]# rpm -q kernel qemu-kvm
kernel-4.2.3-300.fc23.x86_64
qemu-kvm-2.4.0.1-1.fc23.x86_64

[Lenovo T500 Success]
model name    : Intel(R) Core(TM)2 Duo CPU     T9600  @ 2.80GHz
[root@cob-T500 ~]# rpm -q kernel qemu-kvm
kernel-4.2.3-300.fc23.x86_64
qemu-kvm-2.4.0.1-1.fc23.x86_64

[Lenovo T450s Success]
model name :Intel(R) Core(TM) i7-5600U CPU @ 2.60GHz
[prkumar@localhost ~]$ rpm -q kernel qemu-kvm
kernel-4.2.5-300.fc23.x86_64
qemu-kvm-2.4.1-1.fc23.x86_64
Comment 1 Josh Boyer 2015-11-19 09:44:17 EST
Paolo, is this related to bug 1278688?
Comment 2 Dusty Mabe 2015-11-19 12:18:01 EST
As denoted in https://bugzilla.redhat.com/show_bug.cgi?id=1278688 this is fixed in newer versions of the kernel (>4.3).


Using kernel kernel-4.4.0-0.rc1.git0.1.fc24.x86_64 it worked:

dnf install fedora-repos-rawhide
dnf update kernel --enablerepo=rawhide
reboot
Comment 3 Laura Abbott 2016-09-23 15:23:41 EDT
*********** MASS BUG UPDATE **************
 
We apologize for the inconvenience.  There is a large number of bugs to go through and several of them have gone stale.  Due to this, we are doing a mass bug update across all of the Fedora 23 kernel bugs.
 
Fedora 23 has now been rebased to 4.7.4-100.fc23.  Please test this kernel update (or newer) and let us know if you issue has been resolved or if it is still present with the newer kernel.
 
If you have moved on to Fedora 24 or 25, and are still experiencing this issue, please change the version to Fedora 24 or 25.
 
If you experience different issues, please open a new bug report for those.
Comment 4 Dusty Mabe 2016-10-03 09:31:45 EDT
As denoted in comment #2 this is fixed.

Note You need to log in before you can comment on or make changes to this bug.