Bug 128368 - gcc-c++-3.4.1-2 from FC-2.90 doesn't work on i586
gcc-c++-3.4.1-2 from FC-2.90 doesn't work on i586
Status: CLOSED DUPLICATE of bug 127375
Product: Fedora
Classification: Fedora
Component: gcc (Show other bugs)
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Jakub Jelinek
Depends On:
  Show dependency treegraph
Reported: 2004-07-22 04:24 EDT by Constantin
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-02-21 14:04:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Constantin 2004-07-22 04:24:07 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 4.0)

Description of problem:
C++ projects (maybe, C also, I haven't tested them) do not compile on 
586-mmx computer. Compiler reports 'Internal compiler error:Illegal 
instruction'. All is OK on i686 with the same compiler and the same 
projects. Fedora Core 2 native gcc-c++ and gcc34-c++ compile these 
projects well on that 586.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Take old Pentium-MMX class computer
2. Upgrade to gcc-3.4.1-2,gcc-c++,binutils,cpp,libstdc++,libstdc++-
devel,libgcc from Fedora Core 2.90
3. Compile some (different) C++ sources

Actual Results:  'Internal compiler error: Illegal instruction' on 
i586 (FC2)
normal compile on i686 (tested on 3 computers: 1 P4 with FC2, 1 PII 
with RH9 and PII with FC2)

Additional info:

Maybe, the packages are built for i686, but named as i386.rpm
Comment 1 Jakub Jelinek 2004-07-22 04:41:31 EDT
Is this VIA C3?  If yes, this is a big screw-up on VIA side,
the instructions are supposed to be ignored if not implemented already
from i386 UP.
Anyway, GCC no longer uses prefetch with plain -march=i386 -mtune=pentium4,
only -march=i686 -mtune=pentium4 (though it is bad for performance
of the whole distro).

*** This bug has been marked as a duplicate of 127375 ***
Comment 2 Constantin 2004-07-22 05:14:39 EDT
No, it's Intel Pentium MMX (430VX motherboard)
I have used flags -march=pentium-mmx -mcpu=pentium-mmx
Comment 3 Red Hat Bugzilla 2006-02-21 14:04:36 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.