Bug 1283684 - SNMP pollster issue
SNMP pollster issue
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-ceilometer (Show other bugs)
8.0 (Liberty)
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 8.0 (Liberty)
Assigned To: Mehdi ABAAKOUK
Yurii Prokulevych
: Triaged, ZStream
Depends On: 1353857
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-19 10:06 EST by Yurii Prokulevych
Modified: 2016-11-14 14:55 EST (History)
3 users (show)

See Also:
Fixed In Version: openstack-ceilometer-5.0.4-1.el7ost
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-11-14 14:55:58 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
central.log excerpt (9.07 KB, text/plain)
2015-11-19 10:06 EST, Yurii Prokulevych
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 1576577 None None None 2016-04-29 04:29 EDT
OpenStack gerrit 311057 None None None 2016-04-29 04:35 EDT
OpenStack gerrit 311087 None None None 2016-04-29 07:57 EDT

  None (edit)
Description Yurii Prokulevych 2015-11-19 10:06:52 EST
Created attachment 1096715 [details]
central.log excerpt

Description of problem:
Strange traceback in ceilometer/central.log - 
2015-11-19 08:08:48.844 25809 ERROR ceilometer.hardware.pollsters.generic ;RuntimeError: Second simultaneous write on fileno 21 detected.  Unless you really know what you're doing, make sure that only one greenthread can write any particular socket.  Consider using a pools.Pool. If you do know what you're doing and want to disable this error, call eventlet.debug.hub_prevent_multiple_readers(False) - MY THREAD=<built-in method switch of GreenThread object at 0x2da5050>; THAT THREAD=FdListener('write', 21, <built-in method switch of GreenThread object at 0x2da50f0>, <built-in method throw of GreenThread object at 0x2da50f0>)

Looks like some race condition bug cuz after restart it wasn't reproduced.

Version-Release number of selected component (if applicable):
openstack-ceilometer-api-5.0.0-1.el7ost.noarch
openstack-ceilometer-notification-5.0.0-1.el7ost.noarch
openstack-ceilometer-common-5.0.0-1.el7ost.noarch
python-ceilometerclient-1.5.0-1.el7ost.noarch
python-ceilometer-5.0.0-1.el7ost.noarch
openstack-ceilometer-central-5.0.0-1.el7ost.noarch
openstack-ceilometer-polling-5.0.0-1.el7ost.noarch
openstack-ceilometer-alarm-5.0.0-1.el7ost.noarch
openstack-ceilometer-collector-5.0.0-1.el7ost.noarch


How reproducible:
N/A

Actual results:
Traceback in log.

Additional info:
HA virtual setup (3 controller + 1 compute)
Comment 1 Mehdi ABAAKOUK 2016-07-08 04:46:20 EDT
Upstream version 5.0.4 have been released with the fix.
Comment 3 Lon Hohberger 2016-11-08 15:46:51 EST
This is included with the 5.0.4 and 5.0.5 rebases.
Comment 5 errata-xmlrpc 2016-11-14 14:55:58 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2714.html

Note You need to log in before you can comment on or make changes to this bug.