Bug 1283689 - switching workspaces changes top-level window temporarily
switching workspaces changes top-level window temporarily
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: mutter (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Florian Müllner
Fedora Extras Quality Assurance
:
Depends On:
Blocks: WaylandRelated
  Show dependency treegraph
 
Reported: 2015-11-19 10:20 EST by Kamil Páral
Modified: 2016-09-01 02:54 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-09-01 02:54:49 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
bug demonstration video (14.41 MB, application/octet-stream)
2015-11-19 10:21 EST, Kamil Páral
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 758345 None None None Never

  None (edit)
Description Kamil Páral 2015-11-19 10:20:08 EST
Description of problem:
I have two apps on my current workspace, Firefox in front, Terminal in back. When I switch to a workspace below, Terminal is temporarily rendered as a top-level window, during the transition animation. When I switch back to the original workspace, I see again Firefox on top. This is quite jarring and uncomfortable, because the windows jump and flash every time I switch desktop.

This only occurs if I'm using two monitors and there's some window on the secondary screen. If there's no window, the bug doesn't occur.

I tried to capture a screencast. Due to low framerate, it's not that much visible, but in real conditions, the issue is much more obvious. In the video, please note that when Firefox is on top and I switch workspaces, terminal is temporarily rendered on top.

This only happens with Wayland.

Version-Release number of selected component (if applicable):
gnome-shell-3.18.2-2.fc23.x86_64
mutter-3.18.2-1.fc23.x86_64

How reproducible:
always

Steps to Reproduce:
1. have two monitors, open Firefox+Terminal on primary screen and 1 app (hexchat, gedit) on secondary screen
2. make Firefox foreground app
2. switch from first workspace to second workspace, see that the background app is rendered as foreground app temporarily
Comment 1 Kamil Páral 2015-11-19 10:21 EST
Created attachment 1096719 [details]
bug demonstration video
Comment 2 Olivier Fourdan 2016-09-01 02:51:14 EDT
That bug is fixed upstream
Comment 3 Olivier Fourdan 2016-09-01 02:54:49 EDT
https://bugzilla.gnome.org/show_bug.cgi?id=764844

Note You need to log in before you can comment on or make changes to this bug.