Bug 1283697 - Add puppet-opendaylight module
Add puppet-opendaylight module
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-puppet-modules (Show other bugs)
8.0 (Liberty)
Unspecified Unspecified
medium Severity unspecified
: ga
: 8.0 (Liberty)
Assigned To: Jason Guiditta
Itzik Brown
: TechPreview
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-19 10:41 EST by Jason Guiditta
Modified: 2016-08-10 07:44 EDT (History)
8 users (show)

See Also:
Fixed In Version: openstack-puppet-modules-7.0.2-1.el7ost
Doc Type: Technology Preview
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-07 17:12:58 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Gerrithub.io 253988 None None None Never

  None (edit)
Description Jason Guiditta 2015-11-19 10:41:42 EST
Description of problem: For OSP 8, OSPd wants to include support for opendaylight.  To do so, we need to pull the module into opm:

https://github.com/dfarrell07/puppet-opendaylight
Comment 3 Jason Guiditta 2015-12-02 12:47:55 EST
Merged, awaiting rpm
Comment 5 Jason Guiditta 2015-12-21 13:00:30 EST
This can be verfied by ensuring that the openstack-puppet-modules rpm has installed a module to /usr/share/openstack-puppet/modules/opendaylight/.  The module is not yet used, that will come in the related BZ(s).
Comment 8 Amit Ugol 2016-01-25 10:42:22 EST
# tree /usr/share/openstack-puppet/modules/opendaylight/
/usr/share/openstack-puppet/modules/opendaylight/
├── CHANGELOG
├── CONTRIBUTING.markdown
├── files
│   └── upstart.odl.conf
├── Gemfile
├── LICENSE
├── manifests
│   ├── config.pp
│   ├── init.pp
│   ├── install.pp
│   ├── params.pp
│   └── service.pp
├── metadata.json
├── Rakefile
├── README.markdown
├── templates
│   ├── custom.properties.erb
│   ├── jetty.xml.erb
│   └── org.apache.karaf.features.cfg.erb
└── Vagrantfile
Comment 9 errata-xmlrpc 2016-04-07 17:12:58 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-0603.html

Note You need to log in before you can comment on or make changes to this bug.