Bug 1283707 - Clutter docs not available in devhelp on fedora 22 workstation
Clutter docs not available in devhelp on fedora 22 workstation
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: clutter (Show other bugs)
22
i686 Linux
unspecified Severity low
: ---
: ---
Assigned To: Peter Robinson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-19 11:08 EST by Timothy Ward
Modified: 2015-12-12 01:58 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-12 01:58:09 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 758343 None None None Never

  None (edit)
Description Timothy Ward 2015-11-19 11:08:36 EST
Clutter docs not available in devhelp on fedora 22 workstation

Installed Packages
Name        : devhelp
Arch        : i686
Epoch       : 1
Version     : 3.16.1
Release     : 1.fc22
Size        : 993 k
Repo        : @System
Summary     : API documention browser
URL         : https://wiki.gnome.org/Apps/Devhelp
License     : GPLv2+
Description : Devhelp is an API documentation browser for the GNOME desktop.
            : It works natively with API documentation generated by gtk-doc.



Installed Packages
Name        : clutter
Arch        : i686
Epoch       : 0
Version     : 1.22.4
Release     : 1.fc22
Size        : 4.7 M
Repo        : @System
Summary     : Open Source software library for creating rich graphical user
            : interfaces
URL         : http://www.clutter-project.org/
License     : LGPLv2+
Description : Clutter is an open source software library for creating fast,
            : visually rich graphical user interfaces. The most obvious example
            : of potential usage is in media center type applications.
            : We hope however it can be used for a lot more.

How reproducible:

Run devhelp in terminal and read the error messages


Steps to Reproduce:
1. run devhelp in terminal
2. read error messages 
3.

Actual results:
No clutter-docs available

Expected results:

Cluter docs are available
Additional info:
Comment 1 Timothy Ward 2015-11-20 01:46:57 EST
Warning message from Devhelp

(devhelp:4236): Devhelp-WARNING **: Failed to read '/usr/share/gtk-doc/html/clutter-gtk-1.0/clutter-gtk-1.0.devhelp2': Invalid namespace '' at line 3, column 1

[tim@localhost ~]$ ls -l /usr/share/gtk-doc/html/clutter/clutter.devhelp2
-rw-r--r--. 1 root root 372639 Jun 30 20:24 /usr/share/gtk-doc/html/clutter/clutter.devhelp2
Comment 2 Timothy Ward 2015-11-20 02:07:57 EST
Correction info for comment 1 - cally and clutter docs 

(devhelp:4236): Devhelp-WARNING **: Failed to read '/usr/share/gtk-doc/html/cally/cally.devhelp2': Invalid namespace '' at line 3, column 1

[tim@localhost ~]$ ls -l /usr/share/gtk-doc/html/cally/cally.devhelp2
-rw-r--r--. 1 root root 5776 Jun 30 20:24 /usr/share/gtk-doc/html/cally/cally.devhelp2



(devhelp:4236): Devhelp-WARNING **: Failed to read '/usr/share/gtk-doc/html/clutter/clutter.devhelp2': Invalid namespace '' at line 3, column 1

[tim@localhost ~]$ ls -l /usr/share/gtk-doc/html/clutter/clutter.devhelp2
-rw-r--r--. 1 root root 372639 Jun 30 20:24 /usr/share/gtk-doc/html/clutter/clutter.devhelp2




(devhelp:4236): Devhelp-WARNING **: Failed to read '/usr/share/gtk-doc/html/clutter-gtk-1.0/clutter-gtk-1.0.devhelp2': Invalid namespace '' at line 3, column 1

[tim@localhost ~]$ ls -l /usr/share/gtk-doc/html/clutter-gtk-1.0/clutter-gtk-1.0.devhelp2
-rw-r--r--. 1 root root 4022 Jun 30 20:41 /usr/share/gtk-doc/html/clutter-gtk-1.0/clutter-gtk-1.0.devhelp2


same problem as in Bug 1254574
Comment 3 Timothy Ward 2015-12-12 01:58:09 EST
This is not a bug as the clutter-docs package was not installed which contains
/usr/share/gtk-doc/html/clutter-gtk-1.0/clutter-gtk-1.0.devhelp2

Note You need to log in before you can comment on or make changes to this bug.