Bug 1283708 - USB Device passthrough should not be disabled when host doesn't support PCI passthrough
USB Device passthrough should not be disabled when host doesn't support PCI p...
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine
Classification: oVirt
Component: BLL.Virt (Show other bugs)
3.6.0
Unspecified Unspecified
unspecified Severity medium (vote)
: ovirt-3.6.2
: 3.6.2
Assigned To: Martin Betak
Nisim Simsolo
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-19 11:09 EST by Martin Betak
Modified: 2016-02-18 06:19 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-18 06:19:31 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Virt
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
michal.skrivanek: ovirt‑3.6.z?
rule-engine: planning_ack?
michal.skrivanek: devel_ack+
rule-engine: testing_ack+


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 48833 master MERGED backend: Check Host's device passthrough flag only for PCI devices Never
oVirt gerrit 48992 ovirt-engine-3.6 MERGED backend: Check Host's device passthrough flag only for PCI devices Never

  None (edit)
Description Martin Betak 2015-11-19 11:09:29 EST
Description of problem:
The current check of host's device passthrough capability should only be applicable to PCI devices and not other types of passthrough (e.g: USB).

Version-Release number of selected component (if applicable): 3.6.0

How reproducible: 100%

Steps to Reproduce:
1. Have host which is not configured for PCI passthrough
2. Attach a USB device from this host to a VM
3. Try to run the VM

Actual results:
Vm fails to run because it fails to satisfy the HostDeviceFilterPolicyUnit.

Expected results:
Vm should run successfully.
Comment 1 Sandro Bonazzola 2015-12-23 08:43:17 EST
oVirt 3.6.2 RC1 has been released for testing, moving to ON_QA
Comment 2 Nisim Simsolo 2016-02-08 10:06:10 EST
Verified using build: 
rhevm-3.6.3-0.1.el6
qemu-kvm-rhev-2.3.0-31.el7.4.x86_64
vdsm-4.17.19-0.el7ev.noarch
libvirt-client-1.2.17-13.el7_2.2.x86_64

Verification scenario:
1. Verify PCI passthrough is disabled at BIOS level (no Intel vt-d or AMD vi enabled).
2. Verify host IOMMU is disabled (cat /proc/cmdline).
3. Verify host device passthrough is disabled at: webadmin ==> hosts tab ==> general tab.
4. Attach USB device to VM (can be keyboard/mouse/flash drive etc.).
5. Run VM.
6. Verify USB device is attached to VM.
7. Try to run another VM with same device attached and verify VM cannot be run and rejected by webadmin with an appropriate message.
8. Power of VM and verify no errors/exception occurs (vdsm and engine logs).

Test case attached to external trackers.

Note You need to log in before you can comment on or make changes to this bug.