Bug 128373 - /etc/init.d/network will not stop interfaces that have been renamed
Summary: /etc/init.d/network will not stop interfaces that have been renamed
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: initscripts (Show other bugs)
(Show other bugs)
Version: 3.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-07-22 10:47 UTC by Toby Long-Leather
Modified: 2014-03-17 02:46 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-07-23 02:24:26 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Toby Long-Leather 2004-07-22 10:47:42 UTC
Description of problem:
The standard install uses network interface(s) that have the same
interface name and device name (e.g. interface=eth0, device=eth0).

If network interfaces have been renamed (e.g. interface=DMZNet,
device=eth0), then '/etc/init.d/network stop' will not stop the
interface.  This is because the call to check_device_down is passing
the interface name (DMZNet) rather than the device name (eth0).

Version-Release number of selected component (if applicable):
initscripts-7.31.13.EL

How reproducible:
Always

Steps to Reproduce:
1.Create a network interface with an interface name different to
device name.
2. /etc/init.d/network start
3. /etc/init.d/network stop
    

Additional info:

Comment 1 Bill Nottingham 2004-07-22 18:36:20 UTC
Please attach your config.

Comment 2 Toby Long-Leather 2004-07-22 23:14:57 UTC
Will attach copy of /etc/sysconfig/network-scripts/ifcfg-DMZNet next
Monday (the next time I can access the server).  The bug can be fixed
by replacing 'check_device_down $i' with 'check_device_down $DEVICE'.

Comment 3 Bill Nottingham 2004-07-23 02:24:26 UTC
This was fixed in initscripts-7.31.8.EL-1.


Note You need to log in before you can comment on or make changes to this bug.