Bug 1283739 - Repo rhel-7-server-ose-3.1-rpms is not a valid repo
Repo rhel-7-server-ose-3.1-rpms is not a valid repo
Status: CLOSED NOTABUG
Product: OpenShift Container Platform
Classification: Red Hat
Component: Documentation (Show other bugs)
3.1.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Vikram Goyal
Vikram Goyal
Vikram Goyal
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-19 12:14 EST by ebills
Modified: 2016-03-24 08:05 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-19 12:22:18 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description ebills 2015-11-19 12:14:57 EST
Document URL: https://access.redhat.com/documentation/en/openshift-enterprise/version-3.1/installation-and-configuration/#preparing-for-an-automated-upgrade

Section Number and Name: 3.2.1. Preparing for an Automated Upgrade

Describe the issue: [root@master ~]# subscription-manager repos --disable="rhel-7-server-ose-3.0-rpms" --enable="rhel-7-server-ose-3.1-rpms"
Error: rhel-7-server-ose-3.1-rpms is not a valid repository ID. Use --list option to see valid repositories.
Repository 'rhel-7-server-ose-3.0-rpms' is disabled for this system.

Suggestions for improvement: None.  Is this repo active?

Additional information: 
[root@node1 ~]# subscription-manager repos --list |grep rhel-7-server-ose-3.1
[root@node1 ~]# (nothing returned)
Comment 1 ebills 2015-11-19 12:22:18 EST
My mistake here.  Looks like 7.2 is required for OSE 3.1.  

Bug can be closed.
Comment 2 Wesley Hearn 2015-11-20 14:00:23 EST
So if you stumble across this bug and you are running RHEL 7.2 and still cannot see the OSE 3.1 repos you need to force subscription-manager to refresh. Running refresh did not work for me but detaching and re-attaching the entitlement worked(subscription-manager remove --all ; sleep 15 ; subscription-manager attach).
Comment 3 shsrivas 2016-03-24 08:05:26 EDT
Hi Guy 

I am also getting the same problem ,I am on 7.1 .Do I need to upgrade on 7.2.

regards
Shrish

Note You need to log in before you can comment on or make changes to this bug.