Bug 128374 - k3b does not warn when burning files >2GB
Summary: k3b does not warn when burning files >2GB
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: k3b (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-07-22 10:48 UTC by Ralf Ertzinger
Modified: 2014-03-17 02:46 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-07-22 16:09:33 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Ralf Ertzinger 2004-07-22 10:48:10 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20040625

Description of problem:
Note: this may be a problem in dvd+rw-tools/mkisofs, really.

When burning a file larger than 2GB to a DVD+RW (this is that I tried,
I am quite confident it happens with all other types of DVD media,
too), burning the file works just fine, and the resulting media can be
mounted without problems.

However, accessing portions of the file beyond the 2GB barrier fails
(IMHO iso9660 has a 2GB file size limit).

When enabling UDF the media is mounted as UDF, and the complete file
can be accessed.

So, k3b ought to warn the user that there may be trouble reading the
files he is about to burn unless he enables UDF.

Version-Release number of selected component (if applicable):
k3b-0.11.12-2

How reproducible:
Always

Steps to Reproduce:
1. Burn a file larger than 2GB to a DVD
2. Try to read back the file from the media
3.
    

Actual Results:  No warning, but readback fails due to 2GB file size limit

Expected Results:  k3b ought do display a warning to the user.

Additional info:

Comment 1 Justin M. Forbes 2004-07-22 16:09:33 UTC
This has been filed upstream to the KDE bugzilla: 
http://bugs.kde.org/show_bug.cgi?id=85705


Note You need to log in before you can comment on or make changes to this bug.