Bug 1283753 - [RFE][nova] RBD instance snapshots
[RFE][nova] RBD instance snapshots
Status: CLOSED DUPLICATE of bug 1183796
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-nova (Show other bugs)
7.0 (Kilo)
Unspecified Unspecified
high Severity low
: Upstream M3
: 9.0 (Mitaka)
Assigned To: Eoghan Glynn
nlevinki
https://blueprints.launchpad.net/nova...
upstream_milestone_mitaka-3 upstream_...
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-19 12:59 EST by Sean Cohen
Modified: 2016-02-02 14:22 EST (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-02 14:22:03 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenStack gerrit 188244 None None None Never

  None (edit)
Description Sean Cohen 2015-11-19 12:59:32 EST
Description
=========

Taking a snapshot of your virtual machine that is backed by RBD. The snapshot of the disk is saved in Glance, and it can be used to spawn new instances. 

This feature modifies the way Nova does snapshots, eliminating the need to move a copy from local ephemeral storage to the Ceph cluster, but instead making the copy operation internal to the Ceph cluster. 

old path: RBD-> local->Glance->RBD again.
new path: all data path is internal to Ceph

Currently the snapshot has to be offline (Suspend the Guest), but it cam be made live in the future.

The key user ask is the ability to use compute nodes without local storage, and snapshots are the last remaining function requiring significant local storage.

User Stories
==========
* As an Operator, I want to run my compute nodes without any local storage
Comment 2 Sean Cohen 2015-11-19 13:01:45 EST
https://review.openstack.org/#/c/188244/ was merged upstream
Comment 3 Stephen Gordon 2016-02-02 14:22:03 EST

*** This bug has been marked as a duplicate of bug 1183796 ***

Note You need to log in before you can comment on or make changes to this bug.