Bug 1283757 - EC: File healing promotes it to hot tier
EC: File healing promotes it to hot tier
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: tiering (Show other bugs)
3.7.6
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Pranith Kumar K
bugs@gluster.org
: ZStream
Depends On: 1278279 1282761
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-19 13:17 EST by Pranith Kumar K
Modified: 2016-04-19 03:48 EDT (History)
9 users (show)

See Also:
Fixed In Version: glusterfs-3.7.7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1282761
Environment:
Last Closed: 2016-04-19 03:22:11 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Pranith Kumar K 2015-11-19 13:19:42 EST
1) EC Selfheal traffic heats the file, as CTR Xlator is not distinguishing normal read-write FOP traffic from EC Sefheal FOP Traffic. Solution for this is detect the client-pid set in the FOP frame and ignore these FOPS in CTR Xlator. Need info from the EC dev Team, on the which client-pid EC Selfheal daemon uses to mark the FOPS different from regular FOPS.  

2) During a normal write the file gets heated up for read also, which is not correct and has performance cost w.r.t the extra updates to the database.  Well the reason for this is that each write that comes from the user to EC xlator converts to a read-modify-update FOPS. This read FOP doesnt have any marker on it to differentiate it from the regular read, and thus CTR tends to heat up the file.
Would require a marker on this read FOP or any such internal FOPs from EC xlator.
Comment 2 Vijay Bellur 2015-11-19 13:26:51 EST
REVIEW: http://review.gluster.org/12668 (cluster/ec: Mark self-heal fops as internal) posted (#1) for review on release-3.7 by Pranith Kumar Karampuri (pkarampu@redhat.com)
Comment 3 Vijay Bellur 2015-11-19 13:26:56 EST
REVIEW: http://review.gluster.org/12669 (cluster/ec: Mark internal fops appropriately) posted (#1) for review on release-3.7 by Pranith Kumar Karampuri (pkarampu@redhat.com)
Comment 4 Vijay Bellur 2015-11-20 06:17:04 EST
COMMIT: http://review.gluster.org/12669 committed in release-3.7 by Xavier Hernandez (xhernandez@datalab.es) 
------
commit 3748b6540d7704116cbbef08b7401bdc997464cd
Author: Xavier Hernandez <xhernandez@datalab.es>
Date:   Tue Nov 17 14:06:20 2015 +0100

    cluster/ec: Mark internal fops appropriately
    
    1) Mark read fops in read-modify-write by EC as internal.
    2) Handle uid/gid set/reset correctly
    
     >BUG: 1282761
     >Change-Id: I5c1ce0cd6213367eaead5fed33aa2397c4e46df7
     >Signed-off-by: Xavier Hernandez <xhernandez@datalab.es>
     >Reviewed-on: http://review.gluster.org/12599
     >Tested-by: Gluster Build System <jenkins@build.gluster.com>
     >Tested-by: NetBSD Build System <jenkins@build.gluster.org>
     >Reviewed-by: Pranith Kumar Karampuri <pkarampu@redhat.com>
    
    BUG: 1283757
    Change-Id: I9f039cf3ec6351525fb65381bad44d986595844f
    Signed-off-by: Xavier Hernandez <xhernandez@datalab.es>
    Reviewed-on: http://review.gluster.org/12669
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
Comment 5 Vijay Bellur 2016-03-04 02:23:07 EST
REVIEW: http://review.gluster.org/12668 (cluster/ec: Mark self-heal fops as internal) posted (#2) for review on release-3.7 by Pranith Kumar Karampuri (pkarampu@redhat.com)
Comment 6 Vijay Bellur 2016-03-04 20:26:26 EST
COMMIT: http://review.gluster.org/12668 committed in release-3.7 by Pranith Kumar Karampuri (pkarampu@redhat.com) 
------
commit 9504c104d16856095ee99180d38aef02e51b0d60
Author: Pranith Kumar K <pkarampu@redhat.com>
Date:   Tue Nov 17 17:01:47 2015 +0530

    cluster/ec: Mark self-heal fops as internal
    
     >Change-Id: I8ae7af266d3e00460f0cfdc9389a926e5f2fee36
     >BUG: 1282761
     >Signed-off-by: Pranith Kumar K <pkarampu@redhat.com>
     >Reviewed-on: http://review.gluster.org/12598
     >Tested-by: Gluster Build System <jenkins@build.gluster.com>
     >Tested-by: NetBSD Build System <jenkins@build.gluster.org>
     >Reviewed-by: Xavier Hernandez <xhernandez@datalab.es>
    
    BUG: 1283757
    Change-Id: Ic20d4ee031265305db1a6ed2cf591ce94b7d0749
    Signed-off-by: Pranith Kumar K <pkarampu@redhat.com>
    Reviewed-on: http://review.gluster.org/12668
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
Comment 7 Mike McCune 2016-03-28 19:18:47 EDT
This bug was accidentally moved from POST to MODIFIED via an error in automation, please see mmccune@redhat.com with any questions
Comment 8 Kaushal 2016-04-19 03:22:11 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.9, please open a new bug report.

glusterfs-3.7.9 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://www.gluster.org/pipermail/gluster-users/2016-March/025922.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user
Comment 9 Kaushal 2016-04-19 03:48:46 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.7, please open a new bug report.

glusterfs-3.7.7 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://www.gluster.org/pipermail/gluster-users/2016-February/025292.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.