Bug 1283787 - katello-installer --upgrade, fails if a file with .pp extension exist in current working directory
katello-installer --upgrade, fails if a file with .pp extension exist in curr...
Status: CLOSED DUPLICATE of bug 1154170
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Installer (Show other bugs)
6.1.4
Unspecified Linux
unspecified Severity low (vote)
: Unspecified
: --
Assigned To: satellite6-bugs
Katello QA List
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-19 16:29 EST by Harald Jensås
Modified: 2016-08-03 11:22 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-08-03 11:22:16 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Harald Jensås 2015-11-19 16:29:17 EST
Description of problem:
[root@gl-sat01 ~]# katello-installer --upgrade
/usr/share/ruby/vendor_ruby/puppet/parser/parser_support.rb:175:in `rescue in parse': Could not parse for environment production: invalid byte sequence in UTF-8 at /root/mypol.pp:1 (Puppet::Error)
	from /usr/share/ruby/vendor_ruby/puppet/parser/parser_support.rb:166:in `parse'
	from /usr/share/ruby/vendor_ruby/puppet/node/environment.rb:536:in `block in perform_initial_import'
	from /usr/share/ruby/vendor_ruby/puppet/node/environment.rb:534:in `map'
	from /usr/share/ruby/vendor_ruby/puppet/node/environment.rb:534:in `perform_initial_import'
	from /usr/share/ruby/vendor_ruby/puppet/node/environment.rb:255:in `known_resource_types'
	from /usr/share/ruby/vendor_ruby/puppet/resource/type_collection_helper.rb:5:in `known_resource_types'
	from /usr/share/ruby/vendor_ruby/puppet/parser/parser_support.rb:120:in `import'
	from /usr/share/gems/gems/kafo_parsers-0.0.4.4/lib/kafo_parsers/puppet_module_parser.rb:38:in `initialize'
	from /usr/share/gems/gems/kafo_parsers-0.0.4.4/lib/kafo_parsers/puppet_module_parser.rb:16:in `new'
	from /usr/share/gems/gems/kafo_parsers-0.0.4.4/lib/kafo_parsers/puppet_module_parser.rb:16:in `parse'
	from /usr/share/gems/gems/kafo-0.6.5.9/lib/kafo/puppet_module.rb:44:in `parse'
	from /usr/share/gems/gems/kafo-0.6.5.9/lib/kafo/configuration.rb:85:in `block in modules'
	from /usr/share/gems/gems/kafo-0.6.5.9/lib/kafo/configuration.rb:85:in `map'
	from /usr/share/gems/gems/kafo-0.6.5.9/lib/kafo/configuration.rb:85:in `modules'
	from /usr/share/gems/gems/kafo-0.6.5.9/lib/kafo/kafo_configure.rb:170:in `modules'
	from /usr/share/gems/gems/kafo-0.6.5.9/lib/kafo/kafo_configure.rb:152:in `params'
	from /usr/share/gems/gems/kafo-0.6.5.9/lib/kafo/kafo_configure.rb:185:in `set_parameters'
	from /usr/share/gems/gems/kafo-0.6.5.9/lib/kafo/kafo_configure.rb:66:in `initialize'
	from /usr/share/gems/gems/clamp-0.6.2/lib/clamp/command.rb:125:in `new'
	from /usr/share/gems/gems/clamp-0.6.2/lib/clamp/command.rb:125:in `run'
	from /usr/share/gems/gems/kafo-0.6.5.9/lib/kafo/kafo_configure.rb:116:in `run'
	from /usr/sbin/katello-installer:46:in `<main>'
[root@gl-sat01 ~]# ls
anaconda-ks.cfg    katello-inst              manifest_319b9766-8f6a-4b10-b467-42ab966bc956.zip  mypol.pp  puppet_module_builder.patch
ipa-sat6-cert-key  katello-installer-output  module-build.sh                                    mypol.te  ssl-build
[root@gl-sat01 ~]# vim mypol.pp 
[root@gl-sat01 ~]# vim mypol.te 
[root@gl-sat01 ~]# rm mypol.pp mypol.te 
rm: remove regular file ‘mypol.pp’? y
rm: remove regular file ‘mypol.te’? y
[root@gl-sat01 ~]# katello-installer --upgrade

Version-Release number of selected component (if applicable):


How reproducible:
Easy

Steps to Reproduce:
1. touch file.pp
2. cat << EOF > file.pp
ååå
EOF
3. katell-installer --upgrade

Actual results:
/usr/share/ruby/vendor_ruby/puppet/parser/parser_support.rb:175:in `rescue in parse': Could not parse for environment production: invalid byte sequence in UTF-8 at /root/mypol.pp:1 (Puppet::Error)
	from /usr/share/ruby/vendor_ruby/puppet/parser/parser_support.rb:166:in `parse'
	from /usr/share/ruby/vendor_ruby/puppet/node/environment.rb:536:in `block in perform_initial_import'
	from /usr/share/ruby/vendor_ruby/puppet/node/environment.rb:534:in `map'
	from /usr/share/ruby/vendor_ruby/puppet/node/environment.rb:534:in `perform_initial_import'
	from /usr/share/ruby/vendor_ruby/puppet/node/environment.rb:255:in `known_resource_types'
	from /usr/share/ruby/vendor_ruby/puppet/resource/type_collection_helper.rb:5:in `known_resource_types'
	from /usr/share/ruby/vendor_ruby/puppet/parser/parser_support.rb:120:in `import'
	from /usr/share/gems/gems/kafo_parsers-0.0.4.4/lib/kafo_parsers/puppet_module_parser.rb:38:in `initialize'
	from /usr/share/gems/gems/kafo_parsers-0.0.4.4/lib/kafo_parsers/puppet_module_parser.rb:16:in `new'
	from /usr/share/gems/gems/kafo_parsers-0.0.4.4/lib/kafo_parsers/puppet_module_parser.rb:16:in `parse'
	from /usr/share/gems/gems/kafo-0.6.5.9/lib/kafo/puppet_module.rb:44:in `parse'
	from /usr/share/gems/gems/kafo-0.6.5.9/lib/kafo/configuration.rb:85:in `block in modules'
	from /usr/share/gems/gems/kafo-0.6.5.9/lib/kafo/configuration.rb:85:in `map'
	from /usr/share/gems/gems/kafo-0.6.5.9/lib/kafo/configuration.rb:85:in `modules'
	from /usr/share/gems/gems/kafo-0.6.5.9/lib/kafo/kafo_configure.rb:170:in `modules'
	from /usr/share/gems/gems/kafo-0.6.5.9/lib/kafo/kafo_configure.rb:152:in `params'
	from /usr/share/gems/gems/kafo-0.6.5.9/lib/kafo/kafo_configure.rb:185:in `set_parameters'
	from /usr/share/gems/gems/kafo-0.6.5.9/lib/kafo/kafo_configure.rb:66:in `initialize'
	from /usr/share/gems/gems/clamp-0.6.2/lib/clamp/command.rb:125:in `new'
	from /usr/share/gems/gems/clamp-0.6.2/lib/clamp/command.rb:125:in `run'
	from /usr/share/gems/gems/kafo-0.6.5.9/lib/kafo/kafo_configure.rb:116:in `run'
	from /usr/sbin/katello-installer:46:in `<main>'

Expected results:
katello-installer should run, and ignore files in current working dir.

Additional info:
Comment 1 Bryan Kearney 2016-07-26 15:10:02 EDT
Moving 6.2 bugs out to sat-backlog.
Comment 2 Stephen Benjamin 2016-08-03 11:22:16 EDT

*** This bug has been marked as a duplicate of bug 1154170 ***

Note You need to log in before you can comment on or make changes to this bug.