Bug 1283803 - Heapster not collecting network metrics for containers [NEEDINFO]
Heapster not collecting network metrics for containers
Status: CLOSED UPSTREAM
Product: OpenShift Container Platform
Classification: Red Hat
Component: Metrics (Show other bugs)
3.1.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 3.2.1
Assigned To: Jeff Cantrill
chunchen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-19 18:27 EST by Federico Simoncelli
Modified: 2016-09-29 22:17 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-20 08:46:28 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
fsimonce: needinfo? (ccoleman)


Attachments (Terms of Use)

  None (edit)
Description Federico Simoncelli 2015-11-19 18:27:10 EST
Description of problem:
As described in:

https://github.com/kubernetes/heapster/issues/368

"""
Network stats for the pod gcr.io/google_containers/pause:0.8.0 are coming correctly but they are not communicated into influxdb by the heapster.
The containers corresponding to this gcr.io/google_containers/pause:0.8.0 are showing 0 network stats.
"""

Similarly this happens with hawkular (since it's an heapster issue).

How reproducible:
100%

Steps to Reproduce:
1. Deploy openshift-metrics

Actual results:
Network metrics for containers are not collected.

Expected results:
Network metrics for containers should be collected.


Additional info:
Comment 1 Dan McPherson 2015-11-20 08:46:28 EST
I am moving this to trello: https://trello.com/c/9PIFVbyk/171-network-metrics
Comment 2 chunchen 2015-11-22 20:45:09 EST
Will add TCs for the new trello card.

Note You need to log in before you can comment on or make changes to this bug.