Bug 1283814 - Error while sorting tasks
Error while sorting tasks
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS (Show other bugs)
5.5.0
Unspecified Unspecified
medium Severity medium
: GA
: 5.6.0
Assigned To: Jozef Zigmund
Nandini Chandra
ui:task
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-19 19:26 EST by Nandini Chandra
Modified: 2016-06-29 11:04 EDT (History)
4 users (show)

See Also:
Fixed In Version: 5.6.0.6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-06-29 11:04:13 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nandini Chandra 2015-11-19 19:26:47 EST
Description of problem:
--------------------------
The UI blows up with this error while sorting tasks.

No route matches {:action=>"all_ui_jobs", :controller=>"miq_task", :sort_choice=>"Updated"} [miq_task/jobs]


Version-Release number of selected component (if applicable):
----------------------------------
5.5.0.11


How reproducible:
----------------
Always


Steps to Reproduce:
-------------------
1.Navigate to Configure->Tasks
2.Select any tab.
3.Sort on any column.


Actual results:
---------------


Expected results:
----------------


Additional info:
----------------
Comment 2 Nandini Chandra 2015-11-19 23:20:51 EST
Snippet from production.log:

[----] F, [2015-11-19T19:11:55.280813 #14569:b6f990] FATAL -- : Error caught: [ActionController::UrlGenerationError] No route matches {:action=>"all_ui_jobs", :controller=>"miq_task", :sort_choice=>"Updated"}
/opt/rh/cfme-gemset/gems/actionpack-4.2.5/lib/action_dispatch/journey/formatter.rb:46:in `generate'
/opt/rh/cfme-gemset/gems/actionpack-4.2.5/lib/action_dispatch/routing/route_set.rb:721:in `generate'
/opt/rh/cfme-gemset/gems/actionpack-4.2.5/lib/action_dispatch/routing/route_set.rb:752:in `generate'
/opt/rh/cfme-gemset/gems/actionpack-4.2.5/lib/action_dispatch/routing/route_set.rb:799:in `url_for'
/opt/rh/cfme-gemset/gems/actionpack-4.2.5/lib/action_dispatch/routing/url_for.rb:156:in `url_for'
/opt/rh/cfme-gemset/gems/actionview-4.2.5/lib/action_view/routing_url_for.rb:94:in `url_for'
/opt/rh/cfme-gemset/gems/actionview-4.2.5/lib/action_view/helpers/url_helper.rb:181:in `link_to'
/var/www/miq/vmdb/app/views/layouts/gtl/_list.html.haml:30:in `block in _app_views_layouts_gtl__list_html_haml__2568053508681430645_81760080'
/var/www/miq/vmdb/app/views/layouts/gtl/_list.html.haml:25:in `each'
/var/www/miq/vmdb/app/views/layouts/gtl/_list.html.haml:25:in `each_with_index'
/var/www/miq/vmdb/app/views/layouts/gtl/_list.html.haml:25:in `_app_views_layouts_gtl__list_html_haml__2568053508681430645_81760080'
/opt/rh/cfme-gemset/gems/actionview-4.2.5/lib/action_view/template.rb:145:in `block in render'
/opt/rh/cfme-gemset/gems/activesupport-4.2.5/lib/active_support/notifications.rb:166:in `instrument'
/opt/rh/cfme-gemset/gems/actionview-4.2.5/lib/action_view/template.rb:333:in `instrument'
/opt/rh/cfme-gemset/gems/actionview-4.2.5/lib/action_view/template.rb:143:in `render'
/opt/rh/cfme-gemset/gems/actionview-4.2.5/lib/action_view/renderer/partial_renderer.rb:339:in `render_partial'
/opt/rh/cfme-gemset/gems/actionview-4.2.5/lib/action_view/renderer/partial_renderer.rb:310:in `block in render'
/opt/rh/cfme-gemset/gems/actionview-4.2.5/lib/action_view/renderer/abstract_renderer.rb:39:in `block in instrument'
/opt/rh/cfme-gemset/gems/activesupport-4.2.5/lib/active_support/notifications.rb:164:in `block in instrument'
/opt/rh/cfme-gemset/gems/activesupport-4.2.5/lib/active_support/notifications/instrumenter.rb:20:in `instrument'
/opt/rh/cfme-gemset/gems/activesupport-4.2.5/lib/active_support/notifications.rb:164:in `instrument'
/opt/rh/cfme-gemset/gems/actionview-4.2.5/lib/action_view/renderer/abstract_renderer.rb:39:in `instrument'
/opt/rh/cfme-gemset/gems/actionview-4.2.5/lib/action_view/renderer/partial_renderer.rb:309:in `render'
/opt/rh/cfme-gemset/gems/actionview-4.2.5/lib/action_view/renderer/renderer.rb:47:in `render_partial'
/opt/rh/cfme-gemset/gems/actionview-4.2.5/lib/action_view/renderer/renderer.rb:21:in `render'
/opt/rh/cfme-gemset/gems/actionview-4.2.5/lib/action_view/helpers/rendering_helper.rb:32:in `render'
/opt/rh/cfme-gemset/bundler/gems/jquery-rjs-33e0fc1c0b25/lib/jquery-rjs/rendering.rb:8:in `render_with_update'
/var/www/miq/vmdb/app/views/layouts/_gtl.html.haml:29:in `_app_views_layouts__gtl_html_haml___1621734976104839609_81274200'
/opt/rh/cfme-gemset/gems/actionview-4.2.5/lib/action_view/template.rb:145:in `block in render'
/opt/rh/cfme-gemset/gems/activesupport-4.2.5/lib/active_support/notifications.rb:166:in `instrument'
/opt/rh/cfme-gemset/gems/actionview-4.2.5/lib/action_view/template.rb:333:in `instrument'
/opt/rh/cfme-gemset/gems/actionview-4.2.5/lib/action_view/template.rb:143:in `render'
/opt/rh/cfme-gemset/gems/actionview-4.2.5/lib/action_view/renderer/partial_renderer.rb:339:in `render_partial'
/opt/rh/cfme-gemset/gems/actionview-4.2.5/lib/action_view/renderer/partial_renderer.rb:310:in `block in render'
/opt/rh/cfme-gemset/gems/actionview-4.2.5/lib/action_view/renderer/abstract_renderer.rb:39:in `block in instrument'
Comment 3 Harpreet Kataria 2016-05-04 12:05:50 EDT
Jozef,

Can you look into this one, maybe a missing route or the link to sort tasks is incorrect. Let me know if you need help with this one.

Thanks,
~Harpreet
Comment 4 Jozef Zigmund 2016-05-05 11:12:32 EDT
On current master, sorting works as expected, could you verify it ?
Comment 5 Nandini Chandra 2016-05-12 18:29:25 EDT
Verified in 5.6.0.6
Comment 7 errata-xmlrpc 2016-06-29 11:04:13 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1348

Note You need to log in before you can comment on or make changes to this bug.