Bug 1283815 - [f23] selinux-policy-minimum missing requires on provider of /usr/sbin/semanage
[f23] selinux-policy-minimum missing requires on provider of /usr/sbin/semanage
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
23
Unspecified Unspecified
high Severity medium
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-19 20:33 EST by Dusty Mabe
Modified: 2015-12-12 23:22 EST (History)
5 users (show)

See Also:
Fixed In Version: selinux-policy-3.13.1-156.fc23 selinux-policy-3.13.1-157.fc23
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-12 23:22:28 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dusty Mabe 2015-11-19 20:33:18 EST
Description of problem:

If you install selinux-policy-minimum in a container that is based on fedora:23 you will get errors because /usr/sbin/semanage isn't there. 

  Installing  : selinux-policy-minimum-3.13.1-154.fc23.noarch             16/16 
/var/tmp/rpm-tmp.1cC9pn: line 13: /usr/sbin/semanage: No such file or directory

It seems that semanage recently became owned by  policycoreutils-python-utils rather than policycoreutils-python like it was in the past:

[root@f23 tmp]$ rpm -qf /usr/sbin/semanage 
policycoreutils-python-utils-2.4-15.fc23.x86_64



Steps to Reproduce:
# cat <<EOF > Dockerfile
FROM fedora:23
RUN dnf install -y --enablerepo=updates-testing selinux-policy-minimum
EOF
# docker build -t foo .

OBSERVE ERROR
Comment 1 Fedora Update System 2015-12-09 08:38:04 EST
selinux-policy-3.13.1-157.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-b4167d5fd0
Comment 2 Fedora Update System 2015-12-09 23:55:08 EST
selinux-policy-3.13.1-157.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update selinux-policy'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-b4167d5fd0
Comment 3 Fedora Update System 2015-12-12 23:22:10 EST
selinux-policy-3.13.1-157.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.