Bug 1283847 - mapping glitch when using TC apps
mapping glitch when using TC apps
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: device-mapper (Show other bugs)
22
All Linux
unspecified Severity low
: ---
: ---
Assigned To: Orphan Owner
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-20 00:23 EST by Richard Jasmin
Modified: 2015-11-20 01:12 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-20 01:12:03 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Richard Jasmin 2015-11-20 00:23:25 EST
Description of problem:
This is an annoyance, but workable.

When using TC apps like CipherShed/VeraCrypt/GostCrypt(compile from source if the binary wont run) and mapping in a container for the first time since boot, the mapping will fail miserably.

Successive mounts of same container mount fine.
This seems to have to do with the mapper, not the applications use of it as an encrypted container.

Version-Release number of selected component (if applicable):
22+

How reproducible:
always

Steps to Reproduce:
1.try to mount a container(password/keyfile does not matter)
2.insert admin password
3.watch

Actual results:
see above

Expected results:
This issue should never present itself.

Additional info:
This is now what once was TrueCrypt.No, noting is cached.
Comment 1 Milan Broz 2015-11-20 01:12:03 EST
TrueCrypt and derivates are not supported in Fedora because of license issues.

Please use cryptsetup that can mount these volumes as well (it should be supported through standard crypttab keywords).

Alternatively you can use tcplay application.

If you see this problem even with applications above, please attach at least description of configuration, error messages in syslog and systemd journal etc.
Thank you.

Note You need to log in before you can comment on or make changes to this bug.