Bug 128385 - OpenOffice doesn't start / work without internet-connection
OpenOffice doesn't start / work without internet-connection
Status: CLOSED DUPLICATE of bug 124908
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Dan Williams
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-07-22 09:48 EDT by Rainer Rose
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-16 12:10:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rainer Rose 2004-07-22 09:48:50 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; de-AT; rv:1.7) Gecko/20040616

Description of problem:
Simply try to open / create a new document or try to start it.
Nothing happens when you have no internet-connection.


BAD:
When you are working and you pull the network connector�, then try to
create an empty docment. Nothin happens, OpenOffice (=OO) stalled and
displays a grey window.

If you haven't started OO and try to load a document or simply want to
open the Software, the progress bar stopped stops at 100% and nothing
happend.

GOOD:
When you have an internet-connection everything works fine.

� or switch off the router

Version-Release number of selected component (if applicable):
1.1.1-4

How reproducible:
Always

Steps to Reproduce:
Simply want to start OpenOffice.

See description.
    

Actual Results:  Nothing happens. No error message or something like that.

Expected Results:  Should be simply working! With and without
internet-conncetion (expensive)

Additional info:

$ rpm -qa | grep office kernel
openoffice.org-i18n-1.1.1-4
openoffice.org-1.1.1-4
openoffice.org-libs-1.1.1-4
kernel-2.6.6-1.435.2.3
Comment 1 Dan Williams 2004-09-16 22:40:23 EDT
Do you have any network printers configured on your computer?  OOo
uses CUPS which seems to call gethostbyname() which is probably
hanging your computer waiting for a timeout.

#0  0x016fc266 in gethostbyname () from /lib/tls/libc.so.6
#1  0x0277fe1f in httpGetHostByName () from /usr/lib/libcups.so.2
#2  0x0277f921 in httpConnectEncrypt () from /usr/lib/libcups.so.2
#3  0x0277bca6 in cupsGetDests () from /usr/lib/libcups.so.2
#4  0x06473d98 in psp::CUPSManager::tryLoadCUPS () from
/usr/lib/ooo-1.1/program/libpsp645li.so
#5  0x064648ab in psp::PrinterInfoManager::get () from
/usr/lib/ooo-1.1/program/libpsp645li.so
#6  0x00591e4f in SalInstance::GetDefaultPrinter () from
/usr/lib/ooo-1.1/program/libvcl645li.so
#7  0x00489c1a in Printer::GetDefaultPrinterName () from
/usr/lib/ooo-1.1/program/libvcl645li.so
#8  0x0048a2dd in Printer::Printer () from
/usr/lib/ooo-1.1/program/libvcl645li.so
#9  0x07e0232a in SfxPrinter::SfxPrinter () from
/usr/lib/ooo-1.1/program/libsfx645li.so
#10 0xf36c9dfb in ?? () from /usr/lib/ooo-1.1/program/libsw645li.so
#
Comment 2 Dan Williams 2004-09-18 13:07:21 EDT

*** This bug has been marked as a duplicate of 124908 ***

Note You need to log in before you can comment on or make changes to this bug.