Bug 1283877 - journal: cannot remove config /etc/libvirt/qemu/tux1.xml: Operation not permitted
journal: cannot remove config /etc/libvirt/qemu/tux1.xml: Operation not permi...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: resource-agents (Show other bugs)
7.1
All Linux
urgent Severity urgent
: rc
: ---
Assigned To: Oyvind Albrigtsen
cluster-qe@redhat.com
: ZStream
Depends On: 1242558
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-20 02:24 EST by Jan Kurik
Modified: 2015-12-08 05:28 EST (History)
21 users (show)

See Also:
Fixed In Version: resource-agents-3.9.5-54.el7_2.1
Doc Type: Bug Fix
Doc Text:
Previously, the VirtualDomain resource agent (RA) sometimes removed the configuration file, for example if the virtual machine (VM) was added by using the "virsh define /etc/libvirt/qemu/vm.xml" command. As a consequence, the configuration file was sometimes deleted when trying to start the VM again, which caused the VM boot to fail. With this update, a backup file is created and copied back when the configuration file would be otherwise deleted. As a result, the VM starts as expected instead of failing.
Story Points: ---
Clone Of: 1242558
Environment:
Last Closed: 2015-12-08 05:28:37 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Kurik 2015-11-20 02:24:56 EST
This bug has been copied from bug #1242558 and has been proposed
to be backported to 7.2 z-stream (EUS).
Comment 3 Oyvind Albrigtsen 2015-11-20 12:00:22 EST
Reproducible by doing:
# pcs resource disable vm
# virsh define /etc/libvirt/qemu/vm.xml
# pcs resource enable vm

Before:
/etc/libvirt/qemu/vm.xml is removed

After:
/etc/libvirt/qemu/vm.xml is still there
Comment 7 errata-xmlrpc 2015-12-08 05:28:37 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2565.html

Note You need to log in before you can comment on or make changes to this bug.