This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1283879 - ipa-winsync-migrate: Traceback message should be replaced by "IPA is not configured on this system"
ipa-winsync-migrate: Traceback message should be replaced by "IPA is not conf...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: ipa (Show other bugs)
7.2
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: IPA Maintainers
Namita Soman
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-20 02:28 EST by Sudhir Menon
Modified: 2016-11-04 01:40 EDT (History)
3 users (show)

See Also:
Fixed In Version: ipa-4.4.0-0.el7.1.alpha1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-11-04 01:40:59 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sudhir Menon 2015-11-20 02:28:17 EST
Description of problem: When ipa-winsync-migrate command is run on the system which is not yet configured as ipa-server, the traceback message displayed on the console should be replaced with user-friendly message saying that 'IPA is not configured on this system'

Version-Release number of selected component (if applicable): 7.2

How reproducible:Always, when IPA server is not configured on the system

Steps to Reproduce:
1. Login to RHEL7.2
2. Run "yum install ipa-server ipa-server-trust-ad"
3. Ensure "ipa-server-install" is not run.
4. Now do "ipa-winsync-migrate"
5. Now do "ipa-adtrust-install"

Actual results:

4. traceback message is displayed on the console.
[root@ipaserver1 ~]# ipa-winsync-migrate 
ipa: WARNING: session memcached servers not running
Traceback (most recent call last):
  File "/usr/sbin/ipa-winsync-migrate", line 23, in <module>
    WinsyncMigrate.run_cli()
  File "/usr/lib/python2.7/site-packages/ipapython/admintool.py", line 124, in run_cli
    sys.exit(cls.main(sys.argv))
  File "/usr/lib/python2.7/site-packages/ipaserver/install/ipa_winsync_migrate.py", line 346, in main
    api.Backend.ldap2.connect(ccache)
  File "/usr/lib/python2.7/site-packages/ipalib/backend.py", line 63, in connect
    conn = self.create_connection(*args, **kw)
  File "/usr/lib/python2.7/site-packages/ipaserver/plugins/ldap2.py", line 149, in create_connection
    client_controls=clientctrls)
  File "/usr/lib/python2.7/site-packages/ipapython/ipaldap.py", line 1070, in gssapi_bind
    '', auth_tokens, server_controls, client_controls)
  File "/usr/lib64/python2.7/contextlib.py", line 35, in __exit__
    self.gen.throw(type, value, traceback)
  File "/usr/lib/python2.7/site-packages/ipapython/ipaldap.py", line 975, in error_handler
    error=info)
ipalib.errors.NetworkError: cannot connect to 'ldap://localhost:389': 

5. Traceback message is not displayed on the console, although ipa-server-install is not run on the system

[root@ipaserver1 ~]# ipa-adtrust-install 
The log file for this installation can be found in /var/log/ipaserver-install.log
IPA is not configured on this system.


Expected results:
Instead of the traceback message seen in Actual Results 4, the output should be 
similar to what we see in Actual Results 5.

Basically replace traceback message with user-friendly message on the console.


Additional info:
Comment 2 Petr Vobornik 2015-11-20 05:58:44 EST
Upstream ticket:
https://fedorahosted.org/freeipa/ticket/5470
Comment 4 Mike McCune 2016-03-28 18:43:24 EDT
This bug was accidentally moved from POST to MODIFIED via an error in automation, please see mmccune@redhat.com with any questions
Comment 6 Sudhir Menon 2016-07-18 06:23:21 EDT
Traceback is not displayed now when ipa-winsync-migrate command is run without ipa-server installed.

Verified using ipa-server-4.4.0-2.1.el7.x86_64

[root@server ~]# ipa-winsync-migrate 
IPA is not configured on this system.
Comment 8 errata-xmlrpc 2016-11-04 01:40:59 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2404.html

Note You need to log in before you can comment on or make changes to this bug.