Bug 128388 - gtkhtml3 requires the wrong version of its own library
Summary: gtkhtml3 requires the wrong version of its own library
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: gtkhtml3   
(Show other bugs)
Version: rawhide
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Dave Malcolm
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-07-22 14:31 UTC by Michael Young
Modified: 2007-11-30 22:10 UTC (History)
1 user (show)

Fixed In Version: 3.1.18-5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-07-28 16:03:21 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Michael Young 2004-07-22 14:31:32 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20040625

Description of problem:
The gtkhtml3-3.1.18-1.i386.rpm from rawhide reports the following
rpm -qp gtkhtml3-3.1.18-1.i386.rpm --requires
...
libgtkhtml-3.1.so.10
...
rpm -qp gtkhtml3-3.1.18-1.i386.rpm --provides
...
libgtkhtml-3.1.so.11
...
so it is requiring the wrong version of a library it should itself
provide. As a result the package is uninstallable. Presumably
something weird happened in the build of this package - it looks like
the libgnome-gtkhtml-editor-3.1.so library was linked against the
libgtkhtml library on the build system, rather than the version the
package itself built.

Comment 1 Michael Young 2004-07-28 16:03:21 UTC
Fixed now.

Comment 2 David Juran 2005-03-22 20:51:09 UTC
And reappeared now in gtkhtml3-3.6.1-1 )-:

[david@c83-248-3-108 i386]$ rpm -qp --provides gtkhtml3-3.6.1-1.i386.rpm \
|grep libgtkhtml
libgtkhtml-3.6.so.18
[david@c83-248-3-108 i386]$ rpm -qp --requires gtkhtml3-3.6.1-1.i386.rpm|grep \
libgtkhtml
libgtkhtml-3.6.so.15

Plese reopen this bug...

Comment 3 Michael Young 2005-03-22 21:00:17 UTC
If you are referring to the package in rawhide the copy I have just checked
looks okay to me.

Comment 4 David Juran 2005-03-22 22:21:10 UTC
No, the problem occured when I tried to rebuild the source rpm myself on my
RAWHID:ish system. libtool(?) leaves behind the file
libgnome-gtkhtml-editor-3.6.soT which is linked againgst libgtkhtml-3.6.so.15
which I have installed in my system instead of the new one which I try to build.
And then during the install phase this file is copied over to the RPM_BUILD_ROOT


Note You need to log in before you can comment on or make changes to this bug.