Bug 1283883 - ipa upgrade causes vault internal error
ipa upgrade causes vault internal error
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: ipa (Show other bugs)
7.2
All Linux
urgent Severity urgent
: rc
: ---
Assigned To: IPA Maintainers
Namita Soman
: ZStream
Depends On: 1282935
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-20 02:38 EST by Jan Kurik
Modified: 2015-12-08 05:36 EST (History)
12 users (show)

See Also:
Fixed In Version: ipa-4.2.0-15.el7_2.1
Doc Type: Bug Fix
Doc Text:
The IdM KRA agent PEM file was not exported when using ipa-kra-install. Consequently, if KRA was installed after an upgrade from an earlier version of IdM, IdM vault commands failed with an internal error. To fix this bug, the IPA KRA agent PEM file is now exported in ipa-kra-install, and IdM vault commands work in the described situation.
Story Points: ---
Clone Of: 1282935
Environment:
Last Closed: 2015-12-08 05:36:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Kurik 2015-11-20 02:38:10 EST
This bug has been copied from bug #1282935 and has been proposed
to be backported to 7.2 z-stream (EUS).
Comment 4 Nikhil Dehadrai 2015-11-25 10:20:32 EST
Version-Release number of selected component:
ipa-server-4.1.0-18.el7.x86_64
ipa-server-4.2.0-15.el7_2.3.x86_64

Tested the bug with following Steps and observations:

Steps:
------
1.install 7.1 Master
2.ipa upgrade to newest
3.install kra
4.try vault commands

Observations:
-------------
[root@tyan-gt24-03 yum.repos.d]# cat /etc/redhat-release 
Red Hat Enterprise Linux Server release 7.1 (Maipo)
[root@tyan-gt24-03 yum.repos.d]# rpm -qa | grep ipa-server
ipa-server-4.2.0-15.el7_2.3.x86_64
ipa-server-trust-ad-4.2.0-15.el7_2.3.x86_64
ipa-server-dns-4.2.0-15.el7_2.3.x86_64
[root@tyan-gt24-03 yum.repos.d]# ipa-kra-install -p Secret123 -U

===================================================================
This program will setup Dogtag KRA for the IPA Server.


Configuring KRA server (pki-tomcatd). Estimated time: 2 minutes 6 seconds
  [1/8]: configuring KRA instance
  [2/8]: create KRA agent
  [3/8]: restarting KRA
  [4/8]: configure certmonger for renewals
  [5/8]: configure certificate renewals
  [6/8]: configure HTTP to proxy connections
  [7/8]: add vault container
  [8/8]: apply LDAP updates
Done configuring KRA server (pki-tomcatd).
Restarting the directory server
The ipa-kra-install command was successful
[root@tyan-gt24-03 yum.repos.d]# kinit admin
Password for admin@TESTRELM.TEST: 
[root@tyan-gt24-03 yum.repos.d]# ipa vault-add vupgrade --type=symmetric --password='mypa55word'
----------------------
Added vault "vupgrade"
----------------------
  Vault name: vupgrade
  Type: symmetric
  Salt: jD/j/hxa0b1CRFDCNNwZLg==
  Owner users: admin
  Vault user: admin
[root@tyan-gt24-03 yum.repos.d]# echo Secret123 \ base64
Secret123  base64
[root@tyan-gt24-03 yum.repos.d]# echo Secret123  | base64
U2VjcmV0MTIzCg==
[root@tyan-gt24-03 yum.repos.d]# ipa vault-archive vupgrade --password='mypa55word' --
-----------------------------------
Archived data into vault "vupgrade"
-----------------------------------
[root@tyan-gt24-03 yum.repos.d]# grep "KRA is not enabled" /var/log/ipaupgrade.log
2015-11-25T14:42:40Z INFO KRA is not enabled
[root@tyan-gt24-03 yum.repos.d]# ipa vault-add vupgrade --type=symmetric --password='mypa55word'
ipa: ERROR: vault with name "vupgrade" already exists
[root@tyan-gt24-03 yum.repos.d]# ipa vault-archive vupgrade --password='mypa55word' --
-----------------------------------
Archived data into vault "vupgrade"
-----------------------------------
[root@tyan-gt24-03 yum.repos.d]#
[root@tyan-gt24-03 yum.repos.d]# cat /var/log/httpd/error_log | grep ERROR
[root@tyan-gt24-03 yum.repos.d]# cat /var/log/httpd/error_log | grep SSLError
[root@tyan-gt24-03 yum.repos.d]#

Thus based on the above observations no error message is observed, hence marking the status of the bug to "VERIFIED".
Comment 6 errata-xmlrpc 2015-12-08 05:36:59 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2562.html

Note You need to log in before you can comment on or make changes to this bug.