Bug 1283893 - Remove dependency on initscripts unless it is needed
Remove dependency on initscripts unless it is needed
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: hsqldb (Show other bugs)
7.2
Unspecified Unspecified
medium Severity medium
: rc
: 7.3
Assigned To: Mikolaj Izdebski
Vaclav Danek
: EasyFix
Depends On:
Blocks: 1283777
  Show dependency treegraph
 
Reported: 2015-11-20 03:08 EST by Jan Pazdziora
Modified: 2016-11-03 19:31 EDT (History)
5 users (show)

See Also:
Fixed In Version: hsqldb-1.8.1.3-14.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-11-03 19:31:15 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Pazdziora 2015-11-20 03:08:29 EST
Description of problem:

When installing hsqldb in minimal environment like a Docker container, initscripts are pulled in via rpm dependencies, plus another 4.5+ MB worth of dependencies.

I've briefly checked hsqldb rpm scriptlets but nothing from initscripts seems to be used.

Unless there is a strong reason to keep it, it'd be helpful to remove the dependency. Looking at the Fedora hsqldb package, it does not have it.

Version-Release number of selected component (if applicable):

hsqldb-1.8.1.3-13.el7.noarch

How reproducible:

Deterministic.

Steps to Reproduce:
1. docker run -ti rhel7.2 yum install hsqldb

Actual results:

--> Processing Dependency: initscripts for package: 1:hsqldb-1.8.1.3-13.el7.noarch

and initscripts added to the transaction.

Expected results:

initscripts not pulled into the transaction.

Additional info:
Comment 6 errata-xmlrpc 2016-11-03 19:31:15 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2160.html

Note You need to log in before you can comment on or make changes to this bug.