Bug 1283904 - please update s-s-j to latest upstream release
please update s-s-j to latest upstream release
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: system-switch-java (Show other bugs)
7.3
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: jiri vanek
Lukas Zachar
Robert Krátký
:
Depends On: 1283928
Blocks: 1297579 1313485 1080838
  Show dependency treegraph
 
Reported: 2015-11-20 03:50 EST by jiri vanek
Modified: 2016-11-04 00:39 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Rebase: Bug Fixes and Enhancements
Doc Text:
_system-switch-java_ rebased to version 1.7 The _system-switch-java_ package, which provides an easy-to-use tool to select the default Java toolset for the system, has been updated to version 1.7. The new version has been rewritten to support modern JDK packages. The main enhancements include support for multiple Java installations, addition of _-debug_ packages, and support for JDK 9.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-11-04 00:39:23 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description jiri vanek 2015-11-20 03:50:17 EST
The latest upstream release (1.6) contains full support for multiple jdks. With debug packages on board, keeping older s-s-j in rhel 7 is quite useless.
Comment 2 Robert Krátký 2016-04-12 06:51:35 EDT
Hi Jirka,

This bug has been selected for inclusion in 7.3 Release Notes. Could you please add info to the Docs Text field, so that I can use it to formulate the release note?

Thanks.
Comment 6 Robert Krátký 2016-08-21 11:49:15 EDT
Hi Jirka,

Could you please check the Release Notes text?

Thank you.
Comment 7 jiri vanek 2016-09-05 09:43:27 EDT
a) its 1.7 now
b) there is no description what was actually fixed...
 * multiple installs
 * -debug
 * jdk9

As alot of people is not aware of multiple installs and debug subpackages at all, would benice to advertise them a bit.
Comment 8 Robert Krátký 2016-09-05 10:07:31 EDT
Hi Jirka,

I added the info you requested. If you'd like a more detailed description, I'd need to ask you for more input.
Comment 9 jiri vanek 2016-09-05 10:23:23 EDT
sounds good:) TY!
Comment 11 errata-xmlrpc 2016-11-04 00:39:23 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-2361.html

Note You need to log in before you can comment on or make changes to this bug.