Bug 1283915 - Caching of ipaconfig does not work in framework
Caching of ipaconfig does not work in framework
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: ipa (Show other bugs)
7.2
All Linux
urgent Severity urgent
: rc
: ---
Assigned To: IPA Maintainers
Namita Soman
: Regression, ZStream
Depends On: 1283748
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-20 04:28 EST by Jan Kurik
Modified: 2015-12-14 07:11 EST (History)
11 users (show)

See Also:
Fixed In Version: ipa-4.2.0-15.el7_2.1
Doc Type: Bug Fix
Doc Text:
An internal error in the method that cached ipaconfig settings caused the results not to be cached. Consequently, a search for limits stored in LDAP was unintentionally together with every LDAP search operation, and the search operations were thus duplicated. This update fixes the comparison of LDAP connections, and limits are downloaded from LDAP only once for each connection.
Story Points: ---
Clone Of: 1283748
Environment:
Last Closed: 2015-12-08 05:37:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dirsrv_access_log (25.75 KB, text/plain)
2015-11-25 01:59 EST, Abhijeet Kasurde
no flags Details

  None (edit)
Description Jan Kurik 2015-11-20 04:28:20 EST
This bug has been copied from bug #1283748 and has been proposed
to be backported to 7.2 z-stream (EUS).
Comment 5 Abhijeet Kasurde 2015-11-25 01:59 EST
Created attachment 1098576 [details]
dirsrv_access_log
Comment 6 Abhijeet Kasurde 2015-11-25 02:05:35 EST
Verified.

IPA server version::

ipa-server-4.2.0-15.el7_2.2.x86_64


Steps to verify ::

1. Fresh install ipa-server
2. Add IPA user 
3. tail DS access log, usually found /var/log/dirsrv/slapd-<INSTANCE>/access
4. perform operations like 'ipa user-show', 'ipa user-find' and 
5. Grep for string in DS access log
 {{
"SRCH base="cn=ipaconfig,cn=etc,dc=example.com" scope=0 filter="(objectClass=*)" attrs=ALL" 

}}

6. Note that this string should appear once for each request / connection of ipa command.
Comment 9 errata-xmlrpc 2015-12-08 05:37:27 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2562.html

Note You need to log in before you can comment on or make changes to this bug.