This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1283927 - Missing dependency for rear pkg in RHEL 7.2 channel
Missing dependency for rear pkg in RHEL 7.2 channel
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: rear (Show other bugs)
7.2
All Linux
unspecified Severity medium
: rc
: ---
Assigned To: Petr Hracek
Tereza Cerna
:
: 1364373 (view as bug list)
Depends On:
Blocks: 1313485 1289025 1295829
  Show dependency treegraph
 
Reported: 2015-11-20 05:06 EST by Ralf Germann
Modified: 2016-11-03 20:28 EDT (History)
6 users (show)

See Also:
Fixed In Version: rear-1.17.2-2.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-11-03 20:28:42 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ralf Germann 2015-11-20 05:06:58 EST
Description of problem:
The rear-1.17.2-1.el7.noarch has a missing dependency called syslinux. Without this package you will not be able to create any isos from rear and a rear mkrescue will end into an error: 

ERROR: Could not find 'isolinux.bin'. Maybe you have to set ISO_ISOLINUX_BIN [] or install the syslinux package ?
Aborting due to an error, check /var/log/rear/rear-rf-test.log for details

Installation from EPEL channel does install the syslinux requirement.


Version-Release number of selected component (if applicable):
1.17.2-1 on RHEL 7.2 (and maybe in other releases, if you added it also to RHEL 6...)


How reproducible:
Always.


Steps to Reproduce:
1. yum install rear -y
2. rear mkrescue
3. yum install syslinux -y
4. rear mkrescue

Actual results:
rear mkrescue runs into an error due missing dependency syslinux.

Expected results:
The rear pkg should have pkg syslinux as a dependency.

Additional info:
Comment 2 Petr Hracek 2015-11-23 07:01:11 EST
I will provide patch to rear.spec file soon.
Comment 13 Petr Hracek 2016-08-17 08:16:42 EDT
*** Bug 1364373 has been marked as a duplicate of this bug. ***
Comment 16 errata-xmlrpc 2016-11-03 20:28:42 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2208.html

Note You need to log in before you can comment on or make changes to this bug.