Bug 1283930 - ReaR recovery over teaming interface will not work
ReaR recovery over teaming interface will not work
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: rear (Show other bugs)
7.2
x86_64 Linux
unspecified Severity medium
: rc
: ---
Assigned To: Petr Hracek
Tereza Cerna
:
Depends On:
Blocks: 1289025 1305230
  Show dependency treegraph
 
Reported: 2015-11-20 05:14 EST by Ralf Germann
Modified: 2016-11-03 20:28 EDT (History)
4 users (show)

See Also:
Fixed In Version: rear-1.17.2-4.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-11-03 20:28:58 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ralf Germann 2015-11-20 05:14:35 EST
Description of problem:
On RHEL 7.2 with rear-1.17.2-1.el7.noarch a recovery over a configured teaming interface and a network-recovery-service will probably not work due missing routing information.


Version-Release number of selected component (if applicable):
rear-1.17.2-1.el7.noarch on RHEL 7.2


How reproducible:
Create a backup on a system with a teaming-interface as default interface and try to recover from this iso over a network-backup-service as e.g. TSM.


Steps to Reproduce:
1. Create a teaming interface instead of eth0...
2. rear mkrescue
3. Boot from ISO and try to restore.

Actual results:
No working routing and also no working network interface while trying to recover.


Expected results:
A working network connection to recover for example over TSM or other network-based backup tools.


Additional info:
I made a workaround on git for this: https://github.com/rear/rear/pull/662

I simplified the function that all ip-addresses and routing-entries of a teaming-interface will be attached to its first available teaming-member (output by teamdctl).
Comment 13 errata-xmlrpc 2016-11-03 20:28:58 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2208.html

Note You need to log in before you can comment on or make changes to this bug.