Bug 1283931 - kexec-tools fails to update when using NFS share
kexec-tools fails to update when using NFS share
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: kexec-tools (Show other bugs)
7.1
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Xunlei Pang
Shaohui Deng
:
Depends On:
Blocks: 1295826 1296180
  Show dependency treegraph
 
Reported: 2015-11-20 05:15 EST by Bruno Goncalves
Modified: 2016-04-22 01:13 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-25 22:38:36 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bruno Goncalves 2015-11-20 05:15:45 EST
Description of problem:
Update kexec-tools from RHEL-7.1() to RHEL-7.2 () fails.

Error unpacking rpm package kexec-tools-2.0.7-38.el7.x86_64
error: unpacking of archive failed on file /var/crash: cpio: chmod

Version-Release number of selected component (if applicable):
kexec-tools-2.0.7-19.el7.x86_64

How reproducible:
100%

Steps to Reproduce:
1.configure kdump to use an NFS share

2.Boot the server

3.Confirm the NFS share is mounted on /var/crash

4.Try to update kexec-tools


Actual results:
Running transaction
  Updating   : kexec-tools-2.0.7-38.el7.x86_64                                                                                                                                                                 1/2 
Error unpacking rpm package kexec-tools-2.0.7-38.el7.x86_64
error: unpacking of archive failed on file /var/crash: cpio: chmod
kexec-tools-2.0.7-19.el7.x86_64 was supposed to be removed but is not!
  Verifying  : kexec-tools-2.0.7-19.el7.x86_64                                                                                                                                                                 1/2 
  Verifying  : kexec-tools-2.0.7-38.el7.x86_64                                                                                                                                                                 2/2 

Failed:
  kexec-tools.x86_64 0:2.0.7-19.el7                                                                        kexec-tools.x86_64 0:2.0.7-38.el7                                                                       

Complete!
Comment 2 Bruno Goncalves 2015-11-20 05:20:12 EST
The update works after umount /var/crash.

# rpm -q kexec-tools
kexec-tools-2.0.7-38.el7.x86_64
Comment 4 Xunlei Pang 2016-01-13 04:47:41 EST
Hi Bruno,

Seems there's some permission problem with /etc/exports on your NFS server.

I tried with the "no_root_squash" NFS option on my NFS server, the update progress properly. Then I changed "no_root_squash" to "root_squash", met the same problem as your descibed in this bug.

So maybe you can try "no_root_squash" and test it.

Regards,
Xunlei
Comment 5 Bruno Goncalves 2016-01-13 05:44:30 EST
Our NFS server is NetApp, and they do not support no_root_squash, but they allow some other configuration that I could try [1].

But is this really a configuration issue? Note the NFS dump on RHEL-7.1 and 7.2 work well and they are saved to our NFS volume, just during the tool update that the problem happens...

https://kb.netapp.com/support/index?page=content&id=1011504&actp=RSS

If this is just how the update works, I think we can close this as not a bug.
Comment 6 Dave Young 2016-01-13 20:22:35 EST
Hi, Bruno

Can you try mount nfs dir which is created by other packages? See if they handle the update right. I feel it is a general issue not only for kexec-tools.

Thanks
Dave
Comment 7 Bruno Goncalves 2016-01-14 04:30:20 EST
Correct Dave this does not seem to be related to kexec-tools itself.

I've reproduced the problem using util-tools when updating from RHEL-7.1 to 7.2 version.



# mount <NFS share> /usr/share/doc/util-linux-2.23.2/


# yum update util-linux
<snip>
  Updating   : util-linux-2.23.2-26.el7.x86_64                                                                                                                                          5/28 
Error unpacking rpm package util-linux-2.23.2-26.el7.x86_64
error: unpacking of archive failed on file /usr/share/doc/util-linux-2.23.2: cpio: chmod
error: util-linux-2.23.2-26.el7.x86_64: install failed
  Updating   : systemd-219-19.el7.x86_64
Comment 8 Dave Young 2016-01-14 20:52:59 EST
Hi, Bruno

Thanks for verifying, so I think we can regard it as a general issue and this is how update works. Close the bug is good to me.

Thanks
Dave
Comment 9 Xunlei Pang 2016-01-25 22:38:36 EST
We regard this as a general issue, so close it as "not a bug".

Note You need to log in before you can comment on or make changes to this bug.